unable to see custom device in NEEO app after confirming on Mac console.

So I received my NEEO yesterday and have been setting up the devices. I have the dreamscreen lights which is what pushed me towards NEEO after seeing a youtube video of someone controlling the dreamscreen with the NEEO remote.


So now after the setup I find that dreamscreen isn't directly available without some SDK work which I have followed the guide here: https://github.com/nklerk/neeo_driver-DreamScreen


it sounds simple enough, did what it said to do but nothing on the app. 

So I have been searching the net for other things to try and have gone through the SDK test examples: https://github.com/NEEOInc/neeo-sdk-examples but still not able to find any of these custom installed devices from the app.


I followed through this thread https://planet.neeo.com/t/801awx/cant-find-neeo-accessory-on-neeo-app and tried what was said there, I managed to see that the brain and Mac are talking to each other and the app is showing that the SDK is registered but I cannot figure out why I still cannot located the devices.



12replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Anam

    The SDK has to run on an additional device, like a raspberry, your mac, a PC or a NAS. Could you let us know where you are running the SDK?

    It sounds like you were able to get the SDK up and running, what does it say when you start it using the CLI (command line). Does it discover the NEEO Brain or are you seeing any errors?

    Did you ad the DreamScreen driver to package.json so that it is listed as a driver which shall be executed?

    I am hinestly no expert with the SDK. I am sure some other users will quickly jump in here to help.

  • Hi Patrick,


    the SDK is running on my Mac mini which is my media server which I have running all the time. It’s hard wired via Ethernet with a static IP address to avoid any issues. 

    In command line I was able to ping the NEEO brain and when I registered the SDK it did an auto discovery and found the Brain. 

    When I ran the command “node index.js” there was no errors, just dropped to the next line as if it completed the command. However nothing new appeared on the app when I searched for DreamScreen. The same also applies for the simple accessory which I tried to test as I wasn’t having any luck with the dreamscreen package. 

    I didnt add anything to package.json as the driver package was already built and ready to go as it’s listed here on the forum and on github with very easy basic instructions. And to be be honest I don’t know how to add it to package.json. If you can guide me how to check that I will go through and see if there is a problem with it. 

  • Niels de Klerk  Can you help with this as you wrote the driver?


  • Like
    • Anam Hoque could you try typing this

      npm start

    • Niels de Klerk 

      yes the npm start did it! although I did that last time it didn't work. weirdly enough its showing the dreamscreen 4k now. 

      playing with the device which is now working, however the HDMI input changing doesnt seem to work well from neeo. when I press the HDMI input 2 on the dreamscreen app it changes straight away... can this be looked into?


      thanks so much!

    • Anam Hoque 

      I've just updated the driver to version 0.1.1, Could you see if this works better for you?

      • Anam Hoque
      • Anam_Hoque
      • 3 yrs ago
      • 1
      • Reported - view

      Niels de Klerk 

      Thanks, the new driver successfully changes the HDMI input on the dream screen. makes life so much easier now. hopefully the mrs won't call me and complain that the tv isn't working anymore.

      Like 1
  • Niels de Klerk


    Do you know how I can make the npmstart sequence as a Mac startup process? everytime I reboot the Mac I need to go through the commands to start it up, want to be running as a background process without me having to type it in every time.


  • thanks, I sussed out a way using the Mac Automator app.

Like Follow