Upgraded to Shield TV (2017) and can't get it working right

NEEO worked just fine with my original Shield TV using HDMI CEC. Now I upgraded the living room to a newer Shield TV and put the other one in the bedroom, and I simply cannot get my new living room Shield TV working right with NEEO.

The first day I got it, I set it up using HDMI CEC with the NEEO just fine. Everything worked, except that I would have an issue where after turning everything off with NEEO, the Shield TV would after a few seconds turn itself back on (including my TV and receiver). It was annoying, but I dealt with it.

Now today, suddenly the NEEO stopped controlling the Shield TV at all. When I deleted and tried re-adding it to NEEO, it cannot find the Shield over HDMI. I've tried unplugging all of the related equipment and plugging it back in, I've tried disabling and re-enabling the CEC settings on the Shield, but NEEO simply cannot find the Shield any longer, with the same cables and all the same equipment plugged in as I had when it set up fine.

So finally I gave up and decided to set up my FLIRC with the Shield. I set up FLIRC's "Shield TV" profile from my computer and plugged it into the Shield. This step was incredibly frustrating because the test screen to test the FLIRC when adding it to NEEO did not control the Shield at all, so I spent probably an hour troubleshooting the FLIRC until I realized that I just needed to skip the tests and then it worked OK with the Shield.

However now, no matter what combination of settings I choose, I cannot get the NEEO to turn everything off. It turns off the TV and receiver, and then I see the power light on the Shield TV flash off and immediately back on (within like 1/4 of a second), turning everything else on with it. No matter how many times I try, the behavior is consistent.

I'm getting to the end of my wits here. I just want to be able to turn on and off my TV, receiver, and Shield TV together, and to control the Shield TV with my NEEO.

Reply
10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • And really, I want to use HDMI CEC again. Using the FLIRC is annoying and seems unnecessary. I don't get why the Shield can't be found by NEEO even after unplugging the NEEO, receiver, TV, and Shield from power and restarting them. What issues could cause a device to not be able to be detected suddenly?

    I should also mention, the issue with the Shield turning itself back on after it turns off only happens when I use the NEEO to turn it off from what I can tell. If I use the Shield remote to put the Shield to sleep, it turns off my receiver and stays asleep until I wake it up.

    Reply Like
  • Could you try to power off the NEEO brain and then after 30 seconds turn it back on? This will also restart the HDMI-CEC driver, hopefully this works.

    Reply Like
  • Hi,  Ben McClure. Thank you for reporting this. Could you please try to delete your Shield TV once more, unplug your HDMI cable, reboot your NEEO Brain and your router. When it's back online, plug first the NEEO Brain back in, then the HDMI CEC cable.

    Could you also provide me with your NEEO hostname? 

    Should also mention, the issue with the Shield turning itself back on after it turns off only happens when I use the NEEO to turn it off from what I can tell. If I use the Shield remote to put the Shield to sleep, it turns off my receiver and stays asleep until I wake it up.

    Is CEC disabled or enabled on your TV?

    We are aware of some CEC issues. There will come some major CEC improvements with the next firmware release.

    Reply Like
  • When you say to unplug the HDMI cable, do you mean between the NEEO and the receiver, or between the receiver and the Shield? I can just try it with both I suppose.

    I'll give the suggestions from both  Niels de Klerk and Ingrid a try and see if it works, thanks!

    Hostname shows as NEEO-2aebd88c.

    I've tried it with the CEC options both turned on and both turned off on the Shield. I don't recall how the TV is set up for CEC right now, I think its settings got reset when I had it unplugged for a week or so during my move and I may not have gotten everything set up how it was previously.

    I believe CEC is on for my receiver, it automatically turns on a device when switching to its input, however, I use this feature so I'd prefer to leave that enabled if possible.

    The issue with the Shield turning back on only seemed to happen after I tried to set up the new Shield TV, and it got a lot worse using IR through the FLIRC. Maybe if I can get CEC working again instead of using the FLIRC, it'll behave better?

    Reply Like
  • Unplugging the NEEO Brain for ~30 seconds seems to clear this up. However, it's happened two more times since I got it fixed where it just stops controlling anything to do with the Shield until I do this CEC reset procedure.

    Reply Like
  • This still happens pretty much every day and is incredibly frustrating. Here's how it usually goes:

    1. Sit down to watch TV, start my Shield recipe on the Neeo
    2. If the receiver turns on first right away, then it usually means it'll work fine. If the receiver turns on a second or two later, that's how I can tell this issue is present and the following almost always happens.
    3. Everything ends up turned on, but the Neeo can't control the Shield. Commands either don't work at all, or it queues them up and sends one command every 5 or 10 seconds, sometimes even longer. Regular IR commands like changing my receiver volume still work perfectly fine during this time.
    4. The only way to fix it is to unplug the Neeo and plug it back in. After a couple minutes, I can control the shield again.
    5. However, now Neeo has seemingly forgotten how to communicate with the TV and receiver because of the reboot, so when I turn off my recipe, only the Shield turns off, and I have to use another remote to turn off the TV and receiver.
    6. Now if I immediately turn my recipe back on again, everything works fine. Typically it'll keep working for the rest of the day at least before malfunctioning again.

    It's as if whenever some amount of time passes, Neeo's HDMI control starts lagging really bad or not working at all. Every once in a while, it'll work fine for a few days in a row, but the issue always starts again.

    Reply Like 1
      • vistalba
      • vistalba
      • 12 days ago
      • Reported - view

      Ben McClure Exactly same issue here :( Any news about this to solve?

      Reply Like
    • vistalba No, still the same issue after all this time no matter what I try. Now I've resorted to just swearing at it across the room every time I have to get up to go unplug it and plug it back in again, which is every single day. 

       

      I sure wish it would work better, HDMI CEC isn't that complex considering it works fine between all my other devices and only NEEO seems to struggle with it. If the long-promised Bluetooth connectivity would get released, the issue would probably be resolved as well.

      Reply Like
      • vistalba
      • vistalba
      • 11 days ago
      • Reported - view

      Ben McClure There will nothing be resolved in the feature since Neeo get sold to Control4. There is no development anymore on this Product. So it will be in this state forever.

      I hoped thet some of you can give me some hints to get it working...:(

      Reply Like
    • vistalba oh, I didn't realize that, I've still been waiting for another update. How sad, it still doesn't do half the things I bought it to do :(

      Reply Like 1
Like Follow