Z wave controller no reset possible

A couple of months ago I included the brain as secondary Z wave controller but did not use the functions. I deleted it from my primary z wave controller (domoticz). I now have a strange issue with one z wave device that was originally included in the brain. It is a switch that sometimes just turns on and off and I have the idea that it has to do with the neeo brain since I once had the switch turn off just by pressing the volume hard button on the remote.... I also do not see in the domoticz log at times that the switch is turned on and off anything in the log suggesting that the brain sends this z wave signal. in the neeo app I see a couple of offline unknown z wave devices that I cannot delete and reset z wave controller does not work either. it says done but the offline device still show. I also tried "include in existing network" but it says "zwave does not allow learning from another network when z wave devices are already included." But there are no devices included. Is there someway I can totally reset this Z wave part?

14replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Tom den Heijer thanks for the report.

    So you say, that you can't control that switch in question because its listed as unknown device?

    Can you post a screenshot of the "Add discovered devices" (NEEO Brain / Z-Wave actions menu) and "Show unavailable devices".

    In this menu you can also reset the Z-Wave controller

  • Tom den Heijer said:
    I n the neeo app I see a couple of offline unknown z wave devices that I cannot delete and reset z wave controller does not work either. 

    I have seen similar behavior before and I was able to force delete the device. Once the devices were deleted, I was able to reset the Z-Wave controller.

  • Do the "unavailable devices" show up in the normal device list? (Settings -> Devices)

    If so, as Paul said, force-deleting (Click on Device -> Delete -> "My device is broken" -> Force delete) and then resetting the Z-Wave controller might be a good first indicator.

  • I did a force delete and they were deleted from the devices. I then did a reset Z wave controller and it said "done" but I still see in unavailable devices 4 z wave devices (defined as offline). I also cannot include in existing network with a statement that z wave does not allow learning from another network

    • Tom den Heijer 

      Can you show a screenshot of your z-wave menu?

    • Paul Spee The first image is event history right after brain reset z wave ; so it automatically adds some devices. The second image are the devices that cannot be removed and a new inclusion in a z wave network fails.

    • Tom den Heijer 

      i was interested in seeing a screenshot of the z-wave menu, e.g. one level up from the second screenshot.

    • Paul Spee  here you are. i thought this would be the same for all remotes..

    • Tom den Heijer 

      The first command “Include into existing network” will change to “Exclude” if the NEEO has successfully included into an existing network as secondary controller. Obviously it is not running as secondary controller. If you are still see z-wave devices, something weird is going on.

    • Paul Spee Okay thanks. So something weird is going on. Any suggestions how to fix things? I see some strange z wave things going on in my house. Maybe totally factory reset the brain but can i simply restore my recipes?

    • Tom den Heijer 

      i have never tried it, but after a factory reset you may be able to restore from a backup. However, the chances are big that whatever is causing this issue is coming back as well.

      My recommendation is to PM Michael Kohler with your NEEO hostname and see whether he can find anything wrong with your setup before totally wiping it.

      Like 1
  • We know about reports where a reset does not delete all devices in the database and therefore the Brain still has those (but as offline devices). This is extremely hard to debug as it does not happen always and we have indication in which scenarios this happens. Our test engineer is working on this to try to reproduce.

    It is correct that "Include into existing network" does not work as long as there are devices in the database. This is a requirement for all Z-Wave controllers.

    Can you try a factory reset and then restoring from the backup? While this will bring back the Z-Wave devices in the project configuration, you can simply remove them via Settings -> Devices. A factory reset will also wipe any Z-Wave information about the network, so the devices won't be included anymore. It is solely the project configuration that will still hold the entry for the Z-Wave devices with no connection to them whatsoever.

    • Michael Kohler Okay I did a full reset but  when I go to cloud backups no backups are available!

      • Tozz
      • Tozz.1
      • 3 yrs ago
      • Reported - view

      Michael Kohler I am facing this exact issue, and now I can't restore either since apparently I cannot make backups. So the only cloud backup I have is too old.


      There are some other quirks with the Z-Wave implementation:

      1. When nodes are learned, but not fully discovered I can add them, but for example the dimmer slider does not work (it doesn't show in the reomte, but it is selectable). This isn't restoreable either. This is the reason I wanted to clear the configuration. would be great if this issue would be fixed too.
      2. My Brain was a secondary controller in an existing network. I excluded the device from the network (which went fine), but the Z-wave devices were kept in the devices list. I removed them there, but now they show up in the 'Show unavailable devices'. when I click on remove I get an error 'the device could not be removed'.
Like Follow