Remote error "Can not communicate with Brain" after 0.51.13 update

Almost daily the last few weeks. Often after the Remote wasn't used for hours. When it happens, the app/webapp and Brain still work.

I have a Netgear WNDR 3700 router. No mesh. Separate 5 and 2.4 SSID. No spaces. Rebooting the router doesn't help.

I know how to pair the Remote and Brain to get them working again. But it is annoying. Much more so for my girlfriend. Help?

Reply
16replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi,  Mandragore. Thank you for reporting this. Do I understand correctly that you receive the message "Can not communicate with Brain" only since the latest firmware 0.51.13? Is your NEEO Remote also running on firmware 0.51.13? Is your Netgear router up to date? Which Wifi region is set for your router?

    Reply Like
    • Ingrid No, it happens far more often since 0.51.13. It happened sporadically on other firmwares.

      I'm not if sure if we always first get the message "Please wait" before the error, like today. If not always, then very often. 

      Yes, Remote and Brain run 0.51.13.

      Yes, the router software indicates there is no newer firmware.

      The router Wifi region is Europe and I live in Europe.

      Reply Like
    • Mandragore That's interesting that it happens far more often since 0.51.13 as we had some improvements for connection stability in this release. So this was just fixed for your for a very short time, as you mentioned here? Could you please provide me with your NEEO hostname which can be found in your settings in the About section in the NEEO App? Have you already tried to set a static IP address and change your network channel to 1, 6 or 11?

      Please make sure that DHCP is enabled. Did you set for security options WPA/WPA2 encryption? Did you set your 2.4Ghz frequency bandwidth automatically or on 802.11 b, g?

      Reply Like
    • Ingrid Thanks for your help. Correct. The connection was fixed, or so it seemed until about a month ago. And as far as I know nothing changed the last few years. Same router, same router firmware, same router settings and same SSID. All other Wifi connections with laptops, tablets, smartphones etc. work fine and uninterrupted.

      Hostname: NEEO-3736b299
      Static IP address: Not yet. And I'm not sure what can go wrong in my network if I change it to static.
      Channel: 12. Will try other channels.
      DHCP: Enabled, with default starting and ending IP address range.
      Security: WPA2-PSK [AES]
      2.4 Ghz: Up to 300 Mbps. Other options are up to 54 and 130 Mbps. No option for automatically or b/g/n.

      Reply Like
    • Ingrid Also it's getting worse. It now happens every day when we use the remote the first time that day. And it's getting harder to pair again or load the interface. Sometimes I have to power off and on the brain multiple times and sometimes I have to reset the remote multiple times before it loads the interface.

      Once paired again and the interface loaded, the remote keeps working until the next day. Again, even if the remote can't connect, the app/webapp and Brain still work fine. So the remote seems at least to be part of the problem.

      The one day it didn't happen was when I placed the remote on the charger, after shutting down everything and before I went to bed. Then the next day the remote still had a connection to the brain.

      Reply Like
  • Hi, Mandragore. I'm very sorry to hear about this. That's not good news. Was this getting worse after changing the channel to 1, 6 or 11? Usually, we have good experience with one of these channels. Could you try if there is any improvement if you connect your NEEO Brain directly to your router via ethernet cable? Could you also try to perform once recovery mode for your NEEO Remote? 

    To do so, please follow these steps: 

    1. Hold the power button on the NEEO Remote for 15 seconds
    2. Wait a few seconds
    3. Press the power & mute button simultaneously for a few seconds
    4. You should see the option for recovery, follow the on-screen steps
    Reply Like
      • Mandragore
      • Mandragore
      • 1 mth ago
      • 1
      • Reported - view

      Ingrid I had not tried another channel yet when I wrote that. However, tonight the remote couldn't connect, I changed the channel from 12 to 11 and the remote connected by itself, without me pairing again or doing anything else. I hope this is the solution. Thank you!

      Reply Like 1
  • I also have this issue when my router reboots. Usually for firmware updates. I’ve had problems in the past with device association as well with router reboots. 

    Reply Like 1
  • Ingrid Changing the Wifi channel from 12 to 11 solved it. No problems since. Thank you!

    Reply Like 1
  • Mandragore Thanks for coming back to me! That's brilliant! I'm glad to hear that. 🙂

    Reply Like 1
  • Ingrid Unfortunately, with the Wifi channel still on 11, the remote had the same problem the last 3 days, after working just fine for more than a week. Every night it seems to lose the Wifi connection with the brain, because the display doesn't show the Wifi signal strength indicator, when it wakes up.

    As far as I know nothing else changed. So I don't understand why the remote almost never had this problem on previous firmwares, then sometimes on 0.51.13, then every day, then never on channel 11 and now again every day.

    I've just started recovery mode. If that doesn't help, I'll try connecting the router with the ethernet cable. If that doesn't help I could use your help setting a static IP address. I can't find how to do that in my router software and NEEO shouldn't require a network admin 🙂

    Reply Like
      • Mandragore
      • Mandragore
      • 9 days ago
      • Reported - view

      Ingrid Recovery mode didn't help and looking at Pepijn's experience, I'm not sure a fixed IP would fix it. I haven't tried the ethernet cable yet.

      However, after some more troubleshooting the cause seems to be related to the brain, rather than to the remote. Even though the app/webapp connect with the brain, while the remote can't.

      After a yet unknown number of hours of inactivity, the brain looses something that is required for the remote to connect, but is not required for the app/webapp to connect. Perhaps the brain has a remote related time-out or sleep function, causing this. Regardless, I hope this info will help the team to find the cause and fix it.

      Because I've found out that I don't have to reboot the brain and restart the remote and pair them again, to work around it. Now, if I pick up the remote and see that it has no Wifi icon, I don't start any recipe. That will trigger the error.

      I just have to reboot the brain and wait until it's back online. Sometimes that takes a while. Sometimes I reboot it again if takes really long, as if it can't find what it has lost. Anyway, once back online, the remote connects, without me doing anything. I'll know it when I see the Wifi icon. From then on I can use the remote and fire recipes.

      So, I have a slightly more convenient workaround. But I would still very much appreciate not having to reboot the brain so often and wait so long every time to use things controlled by NEEO.

      Reply Like
    • Hi,  Mandragore. Thank you very much for all your information so far. The developers had a look into this. It seems that your NEEO Brain often restarts, which might be just related to your manually reboots. Therefore, it would be helpful to know how often you are doing this restarts per day. Further, can you please confirm that you use the original power cable and power adapter and that you have also installed the ferrite clamps

      Reply Like 1
      • Mandragore
      • Mandragore
      • 3 days ago
      • Reported - view

      Ingrid Thank you and thank the developers, for looking into this!

      I reboot the Brain once per day on weekdays between 17:00 and 21:00, after I get home from work and only when I expect the message. The last few days I didn't need to reboot, because, surprise, surprise, the remote stayed connected. Again, without any changes that I'm aware of.

      So, if the Brain reboots multiple times a day, it's not always me. As far as I know the other devices attached to that source operate without power interrupts.

      Yes, I use the original power cable and adapter. No, I haven't installed the ferrite clamps. I can't remember NEEO came with a manual instructing me to do so. Anyway, I've found the clamps and I will install them if you want.

      Finally, another update on my workaround and when I expect the message. I no longer think it's related to the Wifi icon. Because the last time that I got the message, the remote showed the full Wifi icon. But the other icon, with the bars and dot in the middle, didn't show. Is that the NEEO Link icon?

      The setting 'Prioritize NEEO link' is and was always disabled.

      Reply Like
    • Hi, Mandragore. Thank you for coming back to me. 

      I've found the clamps and I will install them if you want.

      Yes, please. 🙂

      If you have never tried before to enable "Prioritize NEEO link", you could try this for a few days, to see if there is any improvement. A few users mentioned that they had better connectivity when it was enabled. 

      Reply Like
  • I have the same problem with my Netgear Nighthawk X4R7500, so I think there must be a problem with Netgear and the remote. With hte brain there's no problem. A fixed IP doesn't help in my set up.

    I do have another device with this problem, a TP-LINK HS100 wifi plug. It would be nice to have this fixed, now I use a old fashioned non remote plug which switches of the power for a minute around 3AM...

    Reply Like 1
reply to topic
Like1 Follow