Neeo Remote Black screen - Hard buttons work

Having many issues with my Remote, past few weeks the screen has been going black and not being active. Sometimes i could leave it and sometimes i would have to reboot it. Last week i tried a remote recovery after seeing similar threads regarding this and it has not made any difference. Today it wont come back at all, i have tried the reboot and once i did see the Neeo writing briefly but then went black. The remote is active as the hard button continue to work, when you put it on charger it also makes the charging noise. I have reset numerous times (i think) and still nothing.


Is this hardware or firmware issue, any other ideas\fixes to try?

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi,  Jim Trout. Thank you for reaching out to us. Do I understand correctly, that you've tried to force a shutdown by pressing and holding the power button for at least 10 seconds? A short press (3-4 seconds) boots it again.  

    You mentioned above that you have already tried the recovery mode? Is your NEEO Remote fully charged at the moment?  (Another user over here mentioned that a complete discharge of the battery did solve it.) 

    If none of the steps work, please write a message to  with all additional information. (Your details: shipping information, When did it happen? While using it or while charging? What have you already tried so far to recover it ?) Thanks. 

  • Thanks, I have raised this with support and am waiting on a replacement 

Like Follow