Driver for KODI - Version 0.6.0

Available on:

Current features

  • Power on the MediaPC via Wake-on-LAN
  • Optional "exit KODI", "suspend" or "shutdown" the MediaPC on power off
  • Auto reconnect KODI, if connection was lost
  • Start Kodi application on recipe launch implemented.
  • Browsing support for Video, Music, TV Shows and PVR
  • Available as ready to use docker image (currently outdated).

Control functions currently available

  • Power on / off
  • Navigation with control pad
  • Subtitle / Audio / Guide / Info
  • Page up / down
  • Skip next / previous
  • Step back / forward
  • Fast forward / rewind
  • Home / Menu / Info / Back
  • Shortcuts for Videos / Live Tv / Music / Radio

If someone is testing the driver I would appreciate your feedback and suggestions.
 

Reply
180replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Alexander Bauer If you want, you can add your driver over here:

    https://planet.neeo.com/t/q5fql9

    in the Spreadsheet we currently collect all coded Drivers. Thanks!

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Markus Mahr Had I already done so 😉

      Reply Like
  • Hi Alexander, would love to give it a try! (but I´m not a developer (yet ;-))

    I´m using KODI on a Rasberry PII. How and in what system - NEEO or KODI - do I integrate the "driver"?

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Peter Boeijen The neeo drivers are based on node.js. This means you can run the driver on any system with node.js installed. Of course node.js can also installed on an Raspberry PI, but it depends on which base system on your PI is running.
      However, you need at least some very basic knowledge on the linux command line.

      Reply Like
  • Thanks for writing this. I’ve lacked time to finish what I’ve started.

    Reply Like 1
    • Niels de Klerk Please let me know if I can be of any help with testing!

      Groeten uit Berlijn!

      PeterB

      Reply Like
  • Very nice 👍

    Reply Like
  • I have a droidbox kodi, what do I need to do

    Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Aziz Ahmed you need to have a device running node.js to run the "driver" write by Alexander here.. please read the various guides on this site by searching for node or sdk. 

      Reply Like
    • Remko  okay will try to look for it, wished someone could make Vedio of how to

      Reply Like
  • 😒😒😒 have tried confused has hell. Please please please can you just add my Kodi box it’s called droid box t8-s for kodi. 

    Reply Like
  • sorry for the off topic question:

    after the 

    git clone https://github.com/alxbauer/neeo-driver-kodi.git
    

    command, what does the:

    npm install
    

    Do?

    Reply Like
    • Remko the npm reads the Paket and istall all required dependencis witch are not in the hosted git available (e.g. NEEO-SDK ) but you can actually install the packet directly using

      nmp install git+https://github.com/alxbauer/neeo-driver-kodi.git

      Then you get the same result.

      Reply Like
  • cant seem to wake kodi. On my macbook i use a WOL utility thats using port 4343. i changed that in the kodiApi.js but that doesnt seem to help.

    btw, when i edit the kodiApi.js saving and re running the script (index.js) should be enough for changes to take effect right?

    terminal output:

    Wake-on-LAN package sent to: BC:AE:C5:B3:DF:1B

    Socket error: connect EHOSTUNREACH

    Reply Like
    • Remko wake on lan doesn’t use a port as it’s not using TCP nor UDP but ICMP. Woo is also called a magic packet.

      are you sure you are sending a WOL?

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko there is no need to edit kodiApi.js
      For WOL only two parameters in config.js are relevant:

      config.kodi.mac

      and if the Driver is running on Windows:

      config.kodi.broadcastAddress

      WOL won't generate any Error message, because it just sends special network paket and don't care if some client receive this packet.

      The message "Socket error: connect EHOSTUNREACH" came from trying connect KODI on Port 9090, because your KODI is logically not running.

      Are you sure the your Media-PC support WOL? Maybe you have to enable this in BIOS?

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Alexander Bauer im not on windows

      Running this: sudo etherwake -i ens192 BC:AE:C5:B3:DF:1B from the server that is also the node server kodi wakes up fine..

       

      ill try to debug some more here :)

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko I think it's a bug. I fixed this already and will publish a new release tomorrow.

      Reply Like
  • just something i noticed:

    [CONTROLLER] SUBTITLE button pressed

    Unhandled button SUBTITLE pressed

     

    also, on the remote display you have a play and pauze button, they can be one and the same i guess ? 

    btw, i dont have much time, but kodi (and an amp) is my only use for NEEO, so ill definitely going to spend some time on this drive this weekend.. looking forward to if :)

    (running the sdk in a tmux session btw. very handy :)

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko Thank you for the info. That's a bug. "Audio" doesn't work either.

      I'll take care of that for the weekend. I've made a lot of changes to the original code, so I'd like to clean some things up before the next version.

      Reply Like
  • here's a thought, when in kodi menu, channel buttons dont have a function, when in playback mode, the ok and menu button dont seem to have a function, thats a good waste of hardware buttons. Would be nice to utilise dual functions depending on kodi mode, if you get my drift. Would something like this mean extensive editing of the kodi keymap or is this something that can be done from within the driver maybe?

    Reply Like
    • Remko If the Buttons don't be used in Kodi, and this driver is only for Kodi, you can just assign them a function in the driver. Play Pause in the Screen is willed by NEEO and Part of the Default Page. Therefor no change in driver possible.

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Markus Mahr Well, actually, the button IS used when in the kodi menu, but when you are in movie playback, the button doesnt have a relevant use/function. i guess this needs editing from within kodi to assign the one neeo button to sevral functions. This can get very messy soon thought, arg.. i need to sleep on this and read up on the kodi side of things.. 🤓

      Reply Like
    • Remko Yes, then it definitly required to be changed inside of Kodi, the SDK is currently not possible to get a status of what is active and change its own behaviour.

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko I'm working on a solution. I'm not satisfied with that either.

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • 1
      • Reported - view

      I found a solution for that. A new version will be available tomorrow.

      Reply Like 1
  • nice work!

    I have some strange behavior but maybe I've done something wrong:

    I have a small PC in de Livingroom where Win10 is running and Kodi on top. Now I installed Node.js and made a *.bat file where I first start kodi wait 5 seconds and the start the index.js. In the console I can see the your Driver has recognized NEEO and also Kodi. But from time to time when I like to start the kodi recipe on my remote the recipe closes immediately and I have to delete the device in the NEEO App and add the Kodi device once again to get it back working. 

    Did I do something wrong or what might cause this problem?

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Andreas Kraeuchi Does the PC use DHCP to get an IP Address? And maybe the IP Address change between the starts?

      Reply Like
    • Alexander Bauer no, all my devices have static IPs

      Reply Like
    • Alexander Bauer Ok it works now.

      I now added the volume control as well maybe in your next release you could add this too?

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Andreas Kraeuchi I've already implemented it. Will be included in the release tomorrow.

      Reply Like
  • Does this driver work when KODI is not running? Or will it not start? 

    I'm running a dedicated SDK PI. But if I boot the PI and I run this driver on start and KODI instance is not running.
    Will it try to reconnect as fast as KODI starts? Or just fail and stop?

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Anders Ulfheden The driver will run even if Kodi is not running. If Kodi is not running, then you get the following message once "Socket error: connect EHOSTUNREACH". After that the driver tries to reconnect in Background.

      Reply Like
    • Alexander Bauer perfect, great job!

      Reply Like
  • I just released a new version on Github. Almost everything re-coded.

    Please make a fresh installation and re-create your config.js from config.sample.js

    All issuses should be fixed. Let me know if not.

    Reply Like
    • Alexander Bauer thx a lot it works great.

      HOWEVER I think when we call the driver a Mediencenter enter we are no allowed to control the volume on the Mediencenter itself am I right?

      I have re-programmed the driver so it is now a TV and now I can use the volume up and down keys on the remote to control the volume of kodi...

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Andreas Kraeuchi It is not necessary to change the driver type. If you want to control the volume of Kodi, all you have to do is adjust the recipe slightly.
      Go to the "Lauched" part of the recipe and then edit the "Use ... Volume" item. Here you can simply select which device is to be controlled via the volume keys.

      Reply Like
    • Alexander Bauer ok thx didn't see this option, always deleted all Elements in the launched recipe :) 

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Alexander  i suggest putting this in the sample config:

       

      // Set path to KODI executable (optional to start KODI application when the NEEO recipe is launched)
      
      config.kodi.executable = '';

      for non windows systems :)

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko Good idea 😉 It's done.

      Reply Like
  • Alexander Bauer  Super! its working perfectly!! even the wake up. I am thinking about changing channel down to play/pauze in my copy of the code though, having a hardware pauze button is still very handy..  or would it be possible to remap the power button?

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko No. As far as I know, the power button cannot be used. But with the MENU button you get the Kodi OSD. That's ok for me.

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Correction.. WOL still not working.. :(

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko Hmm, i just checked it again. Works fine for me.

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Alexander Bauer  Maybe add a comment here:

      // Only needed for Wake-on-LAN and if you run this driver on Windows

      that it should be empty for non windows systems..  :)  i kept it in because i thought it didnt matter.. but it did!  WOL is working now..

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko It should also work with non-windows systems if the broadcast address is specified correctly. My driver runs on linux without problems.
      However, the broadcast address is only really necessary with windows. And only if the windows computer has configured several network adapters.

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Alexander Bauer oke, but to my understanding, when the user specifies a broadcast address, the script will use that in favour of the other wol method. whats the correct way to specify the broadcast address? what am i looking for? If you dont use windows, shouldnt you best leave the broadcast field empty?

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko There are no different WOL methods. The problem with Windows is that Windows only sends the WOL packet over *one* network adapter if multiple adapters are configured. That's why you have to specify the broadcast address. This tells Windows which adapter to use to send the WOL packet. WOL itself does not need an address or a port.
      Linux and MacOS send the packet over all adapters if no address is given, therefore the address is not necessary. But of course, if the address is correctly specified, it also works under Linux and MacOS. But it doesn't bring any advantage.

      Reply Like
  • Hi it doesn't work and get an error econnrefused 192.168.0.XXX:8080

    I use openelec and can't find the option to switch enable JSON-RPC in KODI 

    Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Rob Dingen did you put the right ip and port for Kodi in the config.js?

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Rob Dingen Settings / Service Settings /Control

      Reply Like
    • Alexander Bauer  Yes but I didn't use a password and leave it like this ( config.kodi.password = ''; )

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      @Rob Dingen Double check these settings:

      config.kodi.ip = '<your-kodi-ip>';
      config.kodi.httpPort = 8080;
      config.kodi.webSocketPort = 9090;
      Reply Like
    • Alexander Bauer They are all correct.

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Rob Dingen Can you post the driver output incl. the error here, please.

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Alexander Bauer use your browser to see if you can log in to Kodi.. i use port 80 in stead of 8080

      (i meant Rob :)

      Reply Like
    • Alexander Bauer 

      ----------------------

       NEEO driver for KODI 

      ----------------------

      [NEEO] Starting API server and connect to Brain: 192.168.X.XXX ...

      [NEEO] Api is ready and running!

       

      [NEEO] ===> Use the NEEO app to search for "KODI" device. <===

       

      [KODI] Try connecting at 192.168.X.XXX:9090 ...

      [KODI] Successfully connected.

      Error: connect ECONNREFUSED 192.168.X.XXX:8080

      [KODI] Active players = 0

      Error: connect ECONNREFUSED 192.168.X.XXX:8080

      Reply Like
    • Remko Yes I can login with port 80 and port 8080 is refused

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Rob Dingen Yeah, then you must adjust the port 😉

      config.kodi.httpPort = 80;
      Reply Like
    • Alexander Bauer Thanks all it works 👍

      Reply Like
  • I was to fast.

    It only works with the terminal window (Mac) open and run node index.js.

    In the terminal window I can see which button pressed and everything works.

    If I close the terminal window it stop working.

    What's wrong and can somebody help me fix this.

    Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Rob Dingen thats because its not running as a service, once you close the terminal the script is terminated. use a program like Tmux or the like to keep  the script running.

      Reply Like
    • Remko Is it not possible to install this as a device and run it only on the brain?

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Rob Dingen in the future, this will be handles by the brain, for now, this is what we have.

      I dont know to install this. A solution like a dedicated RPi running as node server would fix your problem for now i think.

      Reply Like
  • Alexander Bauer Can you (if there are any future updates) add suspend to the power options?

    tnx. for now i hacked it in there myself :)

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Remko Good idea! Coming soon 😀

      Reply Like
  • Hi there,

    What might my issue be here? The driver is recognising the button press, but somethings blowing up preventing it from working.

    Driver is installed to a Raspbian Stretch Lite OS running on a Pi3.

     

    I'd love to initiate WoL to two devices, could I simply clone the config.kodi.mac parameter and add the second MAC (same subnet), or would that break even more things?

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • 1
      • Reported - view

      James Vincent 

      To correct the error, you have to empty the following parameter in the configuration.

      // Set path to KODI executable (optional to start KODI application when the NEEO recipe is launched)
      config.kodi.executable = '';

      At the moment you can't specify a second MAC address, but I can implement it very easily. I'm gonna take a look at this today.

      Reply Like 1
    • Alexander Bauer Thanks! That's got it... At least the WoL aspect :)

      The ability to wake a few would be fantastic, at least for myself. /selfish

      Reply Like
  • There is a new version on Github.

    New features:

    • "Suspend" as an option for the power off function added.
    • Allow Wake-On-Lan for multiple devices. E.g. to start the Media-PC and a NAS device
    • Ability to start multiple driver instances to control multiple KODI instances

    Take a look at the config. sample. js for the new options.

    Reply Like
    • Alexander Bauer Thanks for the update :)

       

      Something to ponder. Users with multiple Brains... I have a Living Room brain and a Bedroom brain. Currently I've got this operating on my Living Room brain, but until (IF) the NEEO's sync, I'm a bit stuck if I want to mirror the config on my Bedroom Brain...

      Reply Like
    • Actually, I'm not sure the MultiBrain is much of an issue given they're HTTP/non IR commands, but what about, 2 separate instances of Kodi on 2 separate devices. (Unless this is what you just introduced and I'm confused how it works).

       

      To expand on my example above, with turning the NAS on.. The NAS is atually in my attic, but the HDMI cable feeds to the bedroom TV. So that could also run Kodi (different IP). My HTPC in the living room, needs the NAS to be on in order to play content.

       

      Also, how do I actually "update" the npm package? I ran npm install git+url, and it overwrote my previous install, so I lost config.js (which given the layout is new in 0.3.0, wasnt too troublesome - for now)...

      Reply Like
  • Alexander Bauer I started using the driver and it works great, except the pad doesn't have any effect when I'm playing a video. Is that expected?

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Sebastien Keller Currently the pad has no function while the player is running. But the following is planned for the next version:

      Up/Down => Skip next / previous
      Left/Right => Fast forward / rewind

      Maybe on weekend.

      Reply Like
    • Alexander Bauer Thanks a lot.

      Any chance to have an option keeping the standard Kodi behavior: http://kodi.wiki/view/Keyboard_controls

      Having used Yatse until now, this seek behaviour is very practical.

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Sebastien Keller I think that's exactly what I planned, but I'm gonna check it again.

      Reply Like
  • It's finally done. Try the new version 0.4.1

    Reply Like 1
  • Hi, I was planning on giving this a test, got my head around setting up node.js and the server side, just wanted to know if this can be setup on the PC that has Kodi on?? I.e. It will be asleep and therefor the server not running?? Or do I need to run it on my Linux server that is always on?? Ta

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • 1
      • Reported - view

      Mark Haywood You can run the driver wherever you want. The only requirement is nodejs and a network connection to the Kodi-PC. Of course, the driver can also run on the Kodi-PC itself.

      Reply Like 1
    • Alexander Bauer thank you, I think I'm almost there, all works except the WOL. As I'm on a windows machine with the node, driver and Kodi then what is the broadcast ip?? It can't be it's own ip as that would be asleep??

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Mark Haywood I'm not sure I understand your problem. Is the driver and Kodi running on the same computer? Then of course WOL does not work.

      Reply Like
    • Alexander Bauer I don't think I was clear in the first post, needing the driver on another system to work the WOL. 

      I'm going to try and set it up on ubuntu server, tho I'm not a great Linux user. 

      Thank you for your great driver!!

      Reply Like
    • Alexander Bauer so I have setup on ubuntu, very easy to do!! Still finding WOL setup hard. If I the network adapter in windows to wake on device the pc never sleeps more that 5 seconds, but the WOL works, if I select wake with magic packet the pc sleeps but the driver WOL doesn't work. Any advise??

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Mark Haywood is this translated by google translate? its very hard to figure out what the setup is and what you like to achieve.

      1: what machine and OS is kodi running on?

      2: what machine/OS  is the Neeo SDK (node.js) running on?

       

      // Only needed for Wake-on-LAN and if you run this driver on Windows

      config.kodi.broadcastAddress = '';

      make sure config.kodi.broadcastAddress is EMPTY! like above when trying WOL on Linux to wake other machines either windows OR linux,

      Reply Like
    • Remko Sorry, no google translate for me.  English is my language, but I'm not super technical.  Let me start again.

       

      I have Kodi setup on a Win7 x64 machine.

      My server is headless Ubuntu machine, that I now run the driver and node.js

      My problem is with WOL on the Win7 machine.  I have setup the WOL in bios, I have changed the power settings in device manager for the network card to "allow this device to wake the computer". There is also another check box "only allow magic packets to wake the computer"

      If i just select the first with no magic packets the WOL works fine, but the PC keeps waking its self, if I select magic packets the PC stays asleep but the WOL from the driver will not wake the PC.

      So i guess I'm asking, is the driver sending the magic packets?  If not I need to disable this and find out what other processes are waking the PC thro the network adapter.

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      @Mark Haywood  OK, I think I understand the problem now.
      "allow this device to wake the computer" is a windows option. This is part of the Windows Power Management and has nothing to do with WOL!


      WOL only needs to be activated in the BIOS.
      The driver sends the "magic packet", which is exactly what WOL does.

      Reply Like
    • Alexander Bauer My HTPC running Kodi is on a Win7 machine.  I activated WOL in the BIOS but it didn't work.  I found that turning these items on in the power management for the network adapter did.  But now I have selected Magic Packet the remote wont wake the HTPC.  I have tested that WOL works as I can wake the HTPC with an app on my phone.

      Allow device to wake activated the HTPC only sleeps for seconds, allow magic packets keeps the HTPC asleep, but I cannot wake with the driver, but I can wake it with an App on my phone.  I'll do a bit more testing, but I dont fully understand how the driver does the WOL.

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Mark Haywood If you can wake your HTPC with an app, then thats good.. dont touch it anymore.. how does your config.js look from row 28 to row 33?  this is mine:

       

      // Hardware (MAC) address of your KODI MediaCenter (optional for Wake-On-LAN)
      
      // You can specify multiple mac addresses separated by commas to start multiple devices. For example, Kodi and your NAS.
      
      config.kodi.mac = 'BC:AE:C5:B3:1B:1A';
      
      
      // Only needed for Wake-on-LAN and if you run this driver on Windows
      
      config.kodi.broadcastAddress = '';

      Aslo, on the ubuntu terminal you can use etherwake to test waking the htpc:

       

      sudo etherwake yourMACadressHere

       

      more here:

      https://www.cyberciti.biz/tips/linux-send-wake-on-lan-wol-magic-packets.html

      Reply Like
    • Remko I'll try to take a look tonight and advise.

      I'm pretty sure the MAC is correct as I copied and pasted from my router (to apply IP to mac).  I think I've put the broadcast IP as the ubuntu server IP.

      Reply Like
    • Remko 

      Reply Like
    • Remko Also tested wakeonlan from the Ubuntu server, all works great.

      Do you think my config.js is correct?

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Mark Haywood  no, 😁

       

      its what i tried explaining before. :)

       

      change this:

      // Only needed for Wake-on-LAN and if you run this driver on Windows
      
      config.kodi.broadcastAddress = '42.0.0.142';

       

      into this:

      // Only needed for Wake-on-LAN and if you run this driver on Windows
      
      config.kodi.broadcastAddress = '';

       

      I made the same mistake..

       

      Alexander Bauer Maybe you should remove the IP in your github source drives or make an extra comment that non windows platforms keep it empty? (Line 33 of config.sample.js)

      Reply Like
    • Remko I just read back thro your earlier post, I'm sorry I didn't spot the comment about leaving that area blank. I'll change it and test tomorrow. Fingers crossed. 

      Reply Like
    • Remko Well what a pain.  I did the changes and updated the config.js.  I decided to reboot and remembered I didnt set up the index.js as a service.  So I tried to start the node.js and get this error.  I'm sure I'm missing something simple, but I'm tired!!

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Mark Haywood you are in the home folder, it cant find the index.js because its not located there. 

      Do this: 

      cd neeo-driver-kodi/src/

      then try again.

      Reply Like
    • Remko Sorry I was tired, yes I had tried in the folder containing index.js

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Mark Haywood hm, now here is where my knowledge stops. Maybe Alexander kan help you out.

      Reply Like
    •  Alexander Bauer Can you please assist?  I'm not sure what I've screwed up??

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Mark Haywood 

      It looks like another service is already running on port 6366.
      You can check this with:

      netstat -apnl | grep -i listen

      But you can simply run the driver on a different port.
      Just change the port in config.js

      // Set the local TCP port for the NEEO REST-WebService
      config.neeo.port = 6336;
      Reply Like
    • Alexander Bauer  So I finally managed to change my port.

      I have the node index.js running ok, I have taken away the broadcast ip, but I still cannot get the HTPC to wake on lan, even tho i can wake it from my phone app.  Any ideas?

      Reply Like
      • Remko
      • Remko
      • 1 yr ago
      • Reported - view

      Mark Haywood check kodi machine mac address and this of course:

      https://planet.neeo.com/r/q5pz9n

      Reply Like
    • Remko We after what seems like forever I have managed to find 10 mins to test and try this little beasty again.

      I set with my Laptop and a linux command line open checking what was happening when I tried buttons.  When i tried to start I had an issue with the location of kodi.exe, as I can start this with another button i took this out of the config.js.  Next I tried the power command (should send wol) i got an error.  Tried Power off, this told me API had stopped, I tried power on and hey presto it works.  I dont know why, but I have simply added power off first then power on and WOL works.  Yippeeeeeee.

      Reply Like
  • I'm trying to make this driver work for me and installed it on my RPI3. This was simple enough and seemed to work. I did notice some double (or not) registering of button presses. My first thought was it's probably wifi related (PI has no cable close) So decided to run it on a Windows machine instead. Unfortunately, after setting up the driver and running it, it never seems to find it in the NEEO app. (This does work when running the driver on the PI) What could a cause for this be? The console is exactly the same when looking at it on the PI or Windows. 

     

    Thanks in advance!

    Reply Like
    • Danny Batenburg I have just installed the server on another system, windows to Linux. Please make sure you remove the device from you app when connected to the first initial server, then create your new server and search again in your neeo app. 

      Id guess that if your not seeing your new server some of your ip settings in config.js are screwed up, or you have dynamic ips and they are changing??

      Reply Like
    • Mark Haywood I am not sure what you mean by server, nodejs? 

      The config files in both cases are supposed to be the same, since the IP address of the brain, and that of the Kodi box is not changing. 

      I started the driver on the Pi again, then removed the entry from the app, stopped the driver on the Pi and started it on the Windows machine. Unfortunately, the result was the same.. 

      The output on the Pi and running on Windows is identical: 

      ---------------------------------------
       NEEO driver for KODI - Version: 0.4.0
      ---------------------------------------
      [NEEO] Connecting Brain ( 192.168.1.88 ) ...
      [NEEO] Starting API server and connect to Brain: 192.168.1.88 ...
      [NEEO] Api is ready and running!
      
      [NEEO] ===> Use the NEEO app to search for "OSMC" device. <===
      
      [KODI] Try connecting at 192.168.1.160:9090 ...
      [KODI] Successfully connected.
      [KODI] Active players = 0

      All this logging makes me think that it is supposed to be working, but still it can't find the device when looking for it in the app. I have also tried using different names for the driver, but i had no luck so far.

      Any other things I could try?

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Danny Batenburg Everything looks good, actually. I also use the driver with Windows and Linux. Windows for development and Linux for production. You can try two different names for "config.neeo.driverManufacturer" in config. js.  Maybe that helps.

      Reply Like
    • Alexander Bauer I caved and went to pull a cable to the pi. Seems it works fine like this, apart from some "double inputs" when clicking the UP button on the remote. 

      All in all, it works, but I am missing one specific button which is to open and start searching for subtitles. I use the "official" ios remote app for kodi usually, and a long-press on the subtitle button comes up with this window. Is this something that can be implemented (or hacked in..) easily?

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Danny Batenburg I have just released version 0.4.2. You have several options now.

      You can configure the function for the button "SUBTITLE" in config.js

      // Subtitle function:
      //    NEXT = Switch to next subtitle
      //    SEARCH = Open subtitle search dialog
      config.kodi.subtitle = 'NEXT';

      I also added two dedicated shortcuts for "next subtitle" and "search subtitle".
      You may need to re-add the device to Neeo for the shortcuts to be available.

      Reply Like
    • Alexander Bauer This seems to be working great! Thanks :) I don't have much reason to use the remote on my phone anymore, which is exactly what I hoped to achieve. 

      Regarding usability, I suppose the Neeo SDK is not aware of a "Long press" ie. keeping the button down on the touchscreen? 

      Reply Like
  • Yeah I'm referring to the nodejs as being the server, might be the wrong term??

    i think I've reached my limit on assisting, tho like you say the log all indicates it's connected and working....

    Reply Like
  • Is it just me, or did the directional buttons (for fastforwarding/skipping) stop working during playback?

    Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Danny Batenburg Should work since version 0.4.x

      Reply Like
    • Alexander Bauer I know, but it's not working in my setup. Did something break? How can I troubleshoot it to get you more info? 

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Danny Batenburg Hmm, it's not so easy to troubleshoot. Do you use a custom player in Kodi?

      Reply Like
    • Alexander Bauer Nope, all default. I could attempt to downgrade to an earlier build just to test, because I seem to remember that I did have it work before.. 

      One thing I should mention is I am running a Kodi 18.x alpha build, I suppose that could influence this? 

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Danny Batenburg

      One thing I should mention is I am running a Kodi 18.x alpha build, I suppose that could influence this?

      I'll check it out this weekend. I've also a test setup with Kodi 18.

      Reply Like
    • Alexander Bauer Great, I'll get back to you on using a downgraded version of the driver. 

      Reply Like
      • Alexander Bauer
      • Software Developer
      • Alexander_Bauer
      • 1 yr ago
      • Reported - view

      Danny Batenburg Version 0.4.3 should now work with Kodi 18 pre-releases.

      Reply Like
Like21 Follow