Onkyo TX-NR609 HDMI CEC issues

Hi,

 

First of all, thank you very much for the last firmware upgrade. Great work.

I'm running into weird issues with HDMI CEC with my Onkyo TX-NR609. I've connected the Neeo Brain to the PC port of my AV receiver. Mostly it works fine, but in combination with my Apple TV 4, something is odd. The AV receiver selects the input PC and stays there. Even if switch it to a different input, it will go back to PC.

I'm wondering now if this is an issue with Neeo or Onkyo. 

Any ideas, how this can be fixed?

 

James

Reply
8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have disabled the CEC on my Onkyo because of strange behaviour. Passthrough CEC signal form NEEO to any device which supoort CEC still works.

    The downside is that without CEC also ARC does not work

    Like
    • Beni 

      I'm using CEC already for a long time with my Onkyo and I've never had any issues. The problems started then, when I connected the Neeo with HDMI, so therefore I am really not convinced, that the Onkyo is the cause of this problem.

       

      Fact is, as soon I am disconnecting the Neeo brain from HDMI, CEC works as expected. The problems occur only with Neeo.

      Like
  • James C. Summers Did you Hotplug the Brain or did you first connect it and then boot it up?

    I had previously issues when using Hotplug HDMI. Often it helps to do a reboot of the trouble device after let it stay for 1-5 min powerless. When a unit detects Hotplug it automatically asks on the CEC if there are devices and what they are actually, sometimes, the units stays in this asking mode and the reciver switches to that input becuase of signals where sended every few seconds / minutes and due to the load it run into strange behaviour.

    Like
  • Markus Mahr Thank you very much for the advice! This was indeed an issue. I've unplugged all the devices from power, waited 5 minutes and turned on the Neeo Brain. After the brain has booted, I've turned on all other devices.

    For over a week, everything forks perfectly now.

    Like
  • Ok I have a question I have an Onkyo TXnr676, but I do not have it hooked up to the NEEO Via HDMI something annoying is happening, I have a recipe to turn on receiver then TV (samsung unc55c80000xfxza) then change input to hdmi2 on tv then show controls to my bell cable receiver and lastly change the input for sound to cable / satellite.

    The annoying part that is happening now is all will work but a few seconds after the recipe does it's thing the input on the Onkyo switches to TV I even have a second command in my recipe to wait 4 sec and send another Input switch to Cable/Satellite but no matter what I manually seem to have to change it back?

     

    I do have CEC enable on my TV and on my DVD and Onkyo  has anyone else encountered this issue and did you fix it ? 

    Like
    • Hi,  Michael Hebert. Thanks for reporting this. Could you please post a screenshot or a video of the recipe steps? Could you also try to add the Shortcut Input Cable/Satelite and test it? Thank you. 

      Like
      • Michael Hebert
      • 2 NEEO owner :)
      • Michael_Hebert
      • 4 yrs ago
      • Reported - view

      Hi Ingrid I turned CEC off on the amp plugged my Neeo to it and that seems to have fixed the issue

      Like
    • Hi,  Michael Hebert. Glad to hear! Please keep me updated if it's fully solved. Thanks. 

      Like
Like Follow