Brain lost Wifi

Just a couple of days after upgrading to newest firmware my Brain lost Wifi connectivity. I managed to connect from app to Brain after connecting Brain to network via ethernet cable, but it will not connect to Wifi anymore. I changed the Wifi password (as I have read others did to fix similar issue) with no success. The message I get is "Unable to connect. Either the password is not correct or the Brain successfully connected to <2.4G network> but can't be reached from <5G network>". What can I do next? Do I have to nuke the brain and hope the cloud backup can recreate the setup? Is that process well tested? I really don't want to have to reconnect all my built in Z-wave gear...

Reply
48replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi, Björn Strömros. Thank you for reaching out to us. Do I understand correctly that you were able to connect your NEEO Brain successfully to a 2.4GHz network? Is your 2.4GHz and 5GHz network running on the same SSID? Does your SSID name contain blank spaces?  Are you able to control any device when your NEEO Brain is connected via ethernet cable? Could you try to set the encryption fixed to WPA or WPA2 (not auto)? 
    Have you already tried to reboot your NEEO Brain (unplug the power cable) and your router once? 

    Reply Like
    • Ingrid Yes, everything worked nice from when I received my Kickstarter Brain/Remote until now. The networks don't have the same name. No network has any space in them. Everything is fine when Brain is connected with cable and I use the iPhone app. Encryption is WPA2. I have rebooted multiple times.

      Reply Like
    • Björn Strömros Do you have a mesh network? Are you using hidden SSID? Could you please try to unplug your NEEO Brain from ethernet and try to access your NEEO Brain over a browser on your PC by using the link: https://>YOUR_IP>:3200/eui (You can find your IP in the About section in the NEEO App.)

      Could you please try turning off your router and your NEEO brain. Turn on the router and wait until it's fully booted up. Then plug in your NEEO brain. (Please try it in this order)

      Reply Like
    • Ingrid , thanks. The dual reboot solved the issue!

      Reply Like
    • Björn Strömros Glad to hear that! Don't hesitate to contact me if you have any further questions. 

      Reply Like
    • Ingrid , I have now had the same issue two more times. I can solve it, but it drives my wife crazy. Have you done a root cause analysis and bug report to the developers?

      Reply Like
    • Hi,  Björn Strömros. That's no good news. I'm really sorry to hear that. Ok, then I'll need some further information. Do you use a dynamic or a static IP? How often does this happen? Is it exactly the same behavior as before (NEEO Brain is losing the Wifi connection)?  

      To which power source is your NEEO brain connected?
      Could you please provide me with your NEEO hostname which can be found in the About section of the NEEO app in your settings? I will forward it to our dev team to check it out. Thank you very much. 

      Reply Like
    •  Ingrid , my external IP is dynamic. This issue has now happened there times in three weeks. Yes, exactly same behaviour. No wifi for the brain, and also for the remote. Brain is now on fixed wire, so App works. My guess some bug was introduced with the release three weeks ago. Didn't have the issue before, and now it keeps reappearing.

      Reply Like
    • Björn Strömros Thank you for your response. It would be also helpful if you could let me know to which power source your NEEO brain is connected?
      Could you please provide me with your NEEO hostname as well, which can be found in the About section of the NEEO app in your settings? I will forward it to our dev team to check it out. Thanks.

      Reply Like
    • Ingrid , what kind of power source kan I choose from?

      Reply Like
    • Ingrid Hostname is NEEO-9b9a81a2.  It would really help if I could just select this text in the iPhone app and copy-paste. 

      Reply Like
    • Ingrid , ping

      Reply Like
    • Björn Strömros Hi, I'm sorry for my late response. We are already working on some fixes for WiFi improvements. Some of them will be in the next firmware releases. At the moment I would suggest trying to set a static IP address and see if that solves it. Do you know the height of your IP range?

         what kind of power source kan I choose from?

      Where is the power cable of the NEEO Brain plugged in? (multiple power socket, wall socket,...) Another question: Do you use any other network devices, like Google devices or an Ethernet Switch? What is the manufacturer and model number of your router? Thank you very much for all information so far. 

      Reply Like
    • Ingrid , the brain is connected to a multiple power socket. Ethernet cable is connected to a switch. Router i a Netgear Nighthawk X6 R8000.

      Reply Like
    • Björn Strömros Thanks, that's very useful. We're getting one step closer. :) Is this Switch also Netgear? Did you try to set a static IP address? Do you also lose Wifi connection if your NEEO Brain is plugged into your Netgear Nighthawk router directly? 

      Reply Like
    • Ingrid The switch is a Zyxel GS-108S. I haven't tried connecting brain directly to router. Did that now. In what context do you talk about static or dynamic IP? Externally I have DHCP, and my brain has DHCP address locally, but I don't think it changes unless I change the network, which I don't. Should I try "static" DHCP for brain right now or wait and see if ordinary DHCP with brain connected directly to Router changes anything? 

      Reply Like
    • Björn Strömros Hi. If it's possible, please leave the ethernet cable plugged into your NEEO Brain without setting static DHCP to see if there is an improvement. In the next firmware release, there will also be some Wifi improvements on the NEEO Brain.

      Reply Like
    • Ingrid , Still having the same problem. :-( Is the new release expected soon?

      Reply Like
    • Björn Strömros I'm sorry to hear that. Even though I can't set any time frame, I can tell you that we are actually very close to the next firmware release. 🙂

      Is your NEEO Brain permanently connected via ethernet for the moment? I will also pull in Jeff as he has also a lot of experience with Wifi connection issues. Thanks for your patience! 

      Reply Like
    • Ingrid , yes directly to the router. 

      Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 6 mths ago
      • Reported - view

      Björn Strömros Hello! Sorry to see that you're still experiencing the same issue. Just to make sure, rebooting your router solves the issue temporarily and then the problem comes back after a week or two?

      Thanks!

      Reply Like
    • Jeff correct

      Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 6 mths ago
      • Reported - view

      Björn Strömros Thank you for the clarification and sorry to hear this continues to be a nuisance to you. As  Ingrid mentioned, we will be releasing a new firmware in the next week or two barring any setbacks. At the moment I suggest we wait for this and see if it helps with this issue. We appreciate your patience in this matter :).

      Thanks!

      Reply Like
  • Ingrid I have a Netgear Orbi wifi and the brain are unable to connect, any fix for it? Thank u

    Reply Like
    • Ngai AC Hi, thank you for reaching out to us. We will need a bit more information. Am I correct, that your Netgear Orbi is a mesh network? What is the exact model number of your device? Is the NEEO Brain connected to a 2.4GHz network? Do you use the same SSID name for your 2.4GHz and 5GHz network? Is your NEEO brain plugged into Ethernet or is it running on WiFi? Did you set up dynamic or static IP address? 

      Reply Like
      • Ngai AC
      • Ngai_AC
      • 8 mths ago
      • Reported - view
      Ingrid said:
      What is the exact model number of your device?

      NetGear Orbi RBR50

      Ingrid said:
      Do you use the same SSID name for your 2.4GHz and 5GHz network?

      Yes, and I'm not sure if I can create a separate 2.4G SSID with Orbi

      Ingrid said:
      Is the NEEO Brain connected to a 2.4GHz network

      Yes, but not to Orbi directly, it's connected to a wifi-repeater with 2.4G SSID

      Ingrid said:
      Is your NEEO brain plugged into Ethernet or is it running on WiFi? 

       Wifi only

      Ingrid said:
      Did you set up dynamic or static IP address?

      I need to get back to you on this, it should be on the default setting. 

      hi Ingrid  

      Sorry for the lack of details. The workaround solution I'm using now is connecting Neeo to a wifi-repeater with 2.4G SSID but it's not an ideal setup for me, hoping there are some smarter solutions from the Neeo team.

      Ps: And I have figured the RC problem I had on the other thread, it was caused by the remote charging station I placed on top of the Brain, it's working fine now. :p

      Thank you!

      Reply Like
    • Ngai AC Hi, thanks for your reply. So, do I understand correctly, that you are not able to get a direct WiFi connection to your NetGear Orbi, only to your WiFi-repeater? Where is your router and your NEEO Brain located? 

      And I have figured the RC problem I had on the other thread, it was caused by the remote charging station I placed on top of the Brain, it's working fine now. :p

      So this thread over here is solved? Glad to hear that! 🙂 I am just a little curious why you have placed the charging station on top of the NEEO Brain. (You don't have to reply on this. 😉)

      Reply Like
      • Ngai AC
      • Ngai_AC
      • 8 mths ago
      • 1
      • Reported - view

      hi   Ingrid Ingrid 

      Ingrid said:
      you are not able to get a direct WiFi connection to your NetGear Orbi, only to your WiFi-repeater

      Yes, the Brain and Remote cannot connect to the Orbi wifi :( 

      Ingrid said:
      Where is your router and your NEEO Brain located

       Pretty close, but not next to each another, probably around 2 – 3m apart only

      Ingrid said:
      curious why you have placed the charging station on top of the NEEO Brain.

      LOL, TBH the Neeo was stacked aside for months cos' the first firmware/UX was too unpleasant to deal with, didn't think of repositioning them when rebooting my smart home project recently.

      But don't get me wrong, I love the Neeo and very reassured by how quickly your team have improved the experience; If Phillips Hue needs 3 gens of app update to be smart, I think you guys are genius from the start :)

      Reply Like 1
    • Ngai AC Please try to separate your network in 2.4 GHz and 5 GHz, as I mentioned above, because the NEEO Brain is not technically capable of handling 5 GHz. That's the reason why your wiFi-repeater (with 2.4 GHz) can connect to your NEEO Brain. Please let me know if that works for you. 

       

      I love the Neeo and very reassured by how quickly your team have improved the experience; If Phillips Hue needs 3 gens of app update to be smart, I think you guys are genius from the start 

      And thank you very much for your great feedback, which absolutely motivates the whole team to keep going. 🙂

      Reply Like
  • I still have the same issue on 0.51.13. Twice in a week now. Are you any closer to understand the root-cause and fix?

    Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 3 wk ago
      • Reported - view

      Björn Strömros Thank you for the update. Have you tried to reboot your router and NEEO Brain too?

      Thanks, 

      Reply Like
    • Jeff Yes, that works everytime. But it is something only I in the household can do...

      Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 3 wk ago
      • Reported - view

      Björn Strömros Can you confirm if you have "prioritize NEEO Link" ON or OFF? When the remote has this issue, can you confirm if you are still able to use the NEEO app?

      Reply Like
    • Jeff It is OFF and I can use the app. 

      Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 3 wk ago
      • Reported - view

      Björn Strömros Thank you for the confirmation. Can you perform a recovery on the NEEO Remote? Please follow these steps in this order:

      A. Recovery on the NEEO Remote

        1. Hold the power button on the NEEO Remote for 15 seconds

        2. Wait a few seconds

        3. Press the power & mute button simultaneously for a few seconds

        4. You should see the option for recovery, follow the on-screen steps

      B. Unplug your router for 2 minutes and then power it back on. After the router is online, wait an additional 3-5 minutes.

        1. Begin the pairing process with the NEEO Remote and Brain.

       

      Let me know if this helps :).

      Reply Like
    • Jeff I don’t have the problem currently since I rebooted router and Brain. Should I do it anyway now, or wait until I have the orovlem agan?

      Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 3 wk ago
      • Reported - view

      Björn Strömros If the problem persists, follow the aforementioned steps :). 

      Reply Like
  • Hello Neeo Team Jeff

    Same issues here since months, tried everything what ive read in here, i changed my wifi too with new hardware to a ubiquity access point, after 6 hours again, no response anymore from the brain, readable in the statistics of the access point. i spent a few 100 bugs for new hardware(fritz boxes, new hp switches, unify access points, tried everything, i have a 2.4 and 5ghz network together same ssid, and i dont wanna change this, thats the last thing i dont tried, but i disabled the 5ghz network for a while, same problems.. please give me one last good idea to do, im just satisfied of the design of the neeo, technically im not happy and it will be exchanged soon with an ugly ir universal remote :-(

    Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 2 wk ago
      • Reported - view

      Florian Grimm Thank you for posting this and sorry that you are experiencing this as well. What happens if you run an ethernet cable to your brain from your router? Does it still lose connection? Do you have assigned IP addresses or are they dynamic?

      Reply Like
    • Hey, thanks for your reaction, i tried also by wire, same problem, after restart it works again. Over wifi i tried fixed and dynamic, actually its set to fixed ones, anymore ideas? Thanks

      Reply Like
    • Florian Grimm does only the remote lose connection or the App as well?

      Reply Like
    • Niels de Klerk mostly the brain, and the wifi logo on the remote is also gone, but all other devices work since 7 years in my wifi here!

      Reply Like
    • Jeff   yep, looses connection also, maybe a "Monday Model" ? new wifi ap's, nosuccess, lan cable, no success, can i get an exchange?

      Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 11 days ago
      • Reported - view

      Florian Grimm Its likely a replacement will not fix the issue. You mentioned you tried new AP's etc. Did you plug your NEEO Brain and enter the new WiFi credentials into the NEEO app and then tied to pair the remote? 

      Reply Like
    • Florian Grimm Make sure you don't have 2 DHCPs in your network (But that would other issues with other devices as well). Power off the Remote, restart your router, once fully started then restart the Remote.

      Reply Like
    • Jeff hey jeff i tried also with a re entering the wifi password, after a while between 1 hour and 1-2 days, the brain cant be reached by ping command anymore, the remote also not reachable. My other 10 wifi devices never had 1 problem to connect and reconnect to the wifi network. I need a solution until sunday, then i kick it out the window! Back to the always working IR remotes!

      thanks for a solution

      Reply Like
  • Update: Ive created a separate WIFI network only for the remote and the brain, same problem... No idea, what i can change.

     

    Last question: Its a US version of the brain, i bought it there, because it tooks that long until Europa was served with Neeo's. But i hope, its equal or switchable in the brain!

     

    Thanks for info

    Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 7 days ago
      • Reported - view

      Florian Grimm That can very well be the problem as EU WiFi channels are different from U.S. I believe you guys have up to channel 13? Can you set your 2.4Ghz to channel 6 and see if that helps?

      Reply Like
Like2 Follow