Brain losing network connection

My Brain starts blinking (white) randomly 1, 2 times a day. It loses both network connections (WiFi & LAN). I have to manually disconnect it from the power source and reboot to reestablish the connection(s).

 

This happens literally every day.

 

I have an Asus RT-N66U router with the latest firmware and DHCP enabled. All other devices in my network have stable connections (wired & wireless).

The brain is connected with the original USB cable and charger that were in the box.

Any help really appreciated, thanks!

Reply
56replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi  Jérôme Matter

    Sorry for the late response on our end here. Can you confirm this is still happening? We just released a new firmware update 0.47.9.

    Thanks!

    Like
  • Hi Jeff

    Thanks for your response.
    I've made a factory reset on my brain (from the app) two days ago and haven't had any issues since then.

    Like
  • Jeff

    Yesterday my remotes became unresponsible again (Cannot communicate with brain). In the app, the brain was found, but I couldn't connect (Brain is busy, please wait until blinking of LED stops).

    But the LED of the brain wasn't blinking at all. After power-cycling the brain all was working again.

    I really hope this will get better, I'll get back to you in a few days.

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Jérôme Matter 

      Thank you for the update. Have you tried the recovery on the NEEO Remote? I know you mentioned all is working, but reinstalling the firmware on the NEEO Remote will help too. You can do this by performing the following steps:

      1. Hold the power button on the NEEO Remote for 15 seconds

      2. Wait a few seconds

      3. Press the power & mute button simultaneously for a few seconds

      4. You should see the option for recovery, follow the on-screen steps

      Like
  • Hi,

    By unit is exhibiting the same behaviour,. Blinking white light - unresponsive every couple days. I need to power-cycle the unit to get it to work.

    ideas?

    tom

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Hi  Tom Berarducci Sorry for the late response on my end here. Moving forward can you please  Jeff (me) so I can be notified :). I will respond in a more timely fashion.

      Are you still experiencing the same issues with your NEEO Brain?

      Thanks! 

      Like
  • Jeff Hi Jeff yes I'm still experiencing the same behavior. Every 24-48 hrs - blinking light - unresponsive until power cycle. I've tried hooking it up via wired ethernet to bypass wifi - no difference in behavior.

    Tom

    Like 1
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Tom Berarducci Thank you for confirming. Can you please email support@neeo.com and we'll go ahead and get that NEEO Brain replaced. Something very strange is happening there.

      Thank you!

      Like
    • Jeff hi same problem here. The brain is losing the connection to the remote 3-4 times a day.

      Restarting the remote doesnt solve the problem. 

      The only solution is to unplug the brain

      im on the newest firmware

      i tried to take some pictures of the remote for your info.

      Like
    • Jeff it happend again

      Like
    • Jeff 

      happend again!

      for your info: the brain light is not blinking.

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Daniel Jordi Thank you for sharing this information. Have you tried to reboot your router? Let's try the following:

      1. Unplug NEEO Brain from power
      2. Reboot router and wait for it to come back online
      3. Plug the supplied ethernet cable into the NEEO Brain and router
      4. Perform WiFi setup once more after the NEEO Brain has a solid white light
      5. I also suggest turning off NEEO Link which is located in settings under NEEO Remote

      Monitor the NEEO and let me know if you experience the same issue once more. 

      Thanks!

      Like
    • Hi Jeff 

      i did both several times.

      i now changed the position of the brain.

      i will let you now if this has any influence.

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Daniel Jordi Just wanted to circle back and ask if anything changed?

      Thanks!

      Like
    • Jeff 

      no, it still happens...

      sometimes every 10min. 🤬

      Sometimes only 1 a day.

      i am waiting for the next firmware, hope it gets better 👍🏻

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Daniel Jordi email support@neeo.com . Let's replace that NEEO Brain. Something weird is going on.

      Thanks!

      Like
    • Jeff OK will do thanks..

      Like
    • Jeff just confirming I got the replacement Black Cat NEEO Brain and I no longer am seeing the "brain losing connection" problem. Working for over 2 weeks now and no issues!

      Thanks all.

      Tom

      Like 2
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Tom Berarducci Thanks for the update, I appreciate it :)

      Like
    • Jeff same issue here. Just reported it today. I cannot connect at all. 

      Like
  • Jeff  Hi Jeff, I also have the same issue. Was working perfectly and had a power cut not the brain blinks every 20-30 minutes. During this time both the app and remote are trying to find the brain.

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Jamie Moore So you experienced a power outage and now the NEEO Brain begins to randomly blink every 20-30 minutes?

      Can you please try the same steps I posted? Let me know if this has any effect.

      Thanks!

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Jamie Moore Just want to circle back on this. If this issue is persistent, please email support@neeo.com and we can replace your NEEO Brain! :)

      Like
    • Jeff hi Jeff, all with Jose at the support desk. Thanks for your help.

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Jamie Moore No worries! Glad we were able to get you going :). 

      Best,

      Like
  • Hi,

    Have the same trouble, 'Cannot communicate with Brain' every day.

    I need to disconnect the power plug of the brain to use the remote

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Marc DILLINGER Thanks for reaching out. Can you DM your NEEO Hostname which can be found in the about section in the NEEO app?

      Thank you!

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Marc DILLINGER Thanks! Can you please try the following if you haven't already:

      1. Unplug NEEO Brain from power
      2. Reboot router and wait for it to come back online
      3. Plug the supplied ethernet cable into the NEEO Brain and router
      4. Perform WiFi setup once more after the NEEO Brain has a solid white light
      5. I also suggest turning off NEEO Link which is located in settings under NEEO Remote
      Like
  • Jeff

    I'm still having outages irregularly, but now with the blinking white light. Sometimes multiple times a day, sometimes after a few days.

    I will DM you the Hostname, hopefully you can find something.

    Thanks!

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Jérôme Matter Thanks for letting me know. Have you rebooted your router? Can you please try this too? I will send your hostname to our dev team to see if they can find anything that can help us.

      Best!

      Like
    • Jeff 

      Yes I have rebooted my router. Currently I have the brain on WiFi and Ethernet. I tried WiFi only but the brain also lost the connection after a certain amount of time.

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Jérôme Matter Thanks for the update. Per our conversation via PM's, I have reported your issue to our devs and once I hear back I will follow up with you.

      Thank you!

      Like
  • I'm having what appears to be the same problem - despite having a ethernet cable connected (with a fixed DHCP reservation from my router to boot), the Brain appears to try to ignore that completely and always focus on the wireless network, with which it loses connectivity regularly, blinking the white LED multiple times a day, often for hours at a time.

    Is there a way to simply disable the wireless network on the brain, or at least get it to prefer the wired connection over the wireless?  Ideally, with the ability to enter a static IP address.

    (Monitoring my network from my router, the remote never drops off the wireless AP because it's much closer to the wireless access point.  The Brain is literally 12 ft from my core network switch, however, and has no need of wireless as long as the wired connection works.)

    While we're at it, any word on getting the Neeo to work with hidden SSIDs?

    Thanks.

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Talesio! Hello! Have you attempted removing the static IP and leave everything Dynamic? Have you also attempted to reboot your NEEO Brain? You can do perform a data reset and it will allow you to setup your NEEO Brain from scratch. When you are prompted to connect the brain to WiFi, you can skip this step.

      Let me know if these steps help.

      Thanks!

      Like
      • Talesin
      • Brian_Jones
      • 2 yrs ago
      • Reported - view

      Jeff Thanks for the response.

      My mention of using a static IP was a request, as I'm not aware that the Neeo Brain has this ability today.  Does it?

      Given that I'm not aware of the ability to set a static IP, yes, my setup actually uses DHCP.  (Though I have a reservation set on the router so that the Brain always gets the same DHCP address.)

      I will try the data reset and see if I can skip the step.  Having said that, exposing the ability to select networks (wired vs. wifi) in the software would be an excellent idea.

      I'll be back after I reset the Brain...

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Talesin  You can set a static IP to any device I believe. This would be done through your routers interface and not related to NEEO. 

      I look forward to your response. Let me know if rebooting your router and NEEO help too.

      Thanks!

      Like
      • Talesin
      • Brian_Jones
      • 2 yrs ago
      • Reported - view

      Jeff 

      Hi Jeff.  A static IP address is set in the device.  A DHCP reservation is set at the router.

      I have static IP addresses set everywhere I can, and prefer them.  As an example, the time it took my Panasonic TV to negotiate its Internet connection on start-up went from maybe 20 second when using DHCP to virtually instant when using static IPs.

      I'll test as soon as I'm out of meetings.

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Talesin If you can test by removing NEEO from any type of IP reservation, that would be great to help isolate the issue.

      Thanks!

      Like
      • Talesin
      • Brian_Jones
      • 2 yrs ago
      • Reported - view

      Jeff 

      Ok, I reset the Brain, did not configure WiFi, and turned off DHCP reservations (confirmed as I can see a new IP address assigned to it).  The Brain still refuses to stay connected to the network.  It almost constantly blinks, with only short periods of connectivity.

      What else can we try?  Thanks.

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Talesin Let's try one more brain reboot and if that does not help, email support@neeo.com . We can proceed from there with a replacement.

      Thanks!

      Like
      • Talesin
      • Brian_Jones
      • 2 yrs ago
      • Reported - view

      Jeff 

      I tried a reboot, and it came up long enough that I tried to re-pair the remote.  (There was at least one other "blinking session" along the way.). It wouldn't pair.  Tried another Brain reset from scratch, enabled wifi, and was able to re-pair the remote.  Couldn't stay connected long enough to configure any devices, however - more blinking.

      (Note that I get blinking sessions whether the wireless network is on or off, but I seem to get more when the wireless network is on - it feels as if the Neeo biases toward the wireless network even when it has a wired connection which will virtually always more the more reliable link.)

      I will contact support.

      I have to say that this is the most unstable piece of technology that I've ever purchased, especially at this price.  I've had it (and one replacement already) since November and I have yet to execute more than partial recipes, much less do so reliably over time.  I would strongly advice Neeo to forgo adding more integrations for a while and focus on basic reliability and stability (and solidifying the network stack, including hidden SSIDs, static IPs, ability to turn on and off the wired vs. wireless interfaces, etc.).  There is potential here in both ultimate capability and the elegance of the interface, but above all else, it has to work.  I'm stubborn and want to try to get the product to work, but aside from the financial cost, the time spent debugging is asking too much; so far, I most definitely regret the purchase.  (The more problems I encounter, the more I fear that the solutions will eventually require a hardware rev to fix.)

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Talesin Thank you for the update and feedback. Can you please email support@neeo.com ? If you can include the NEEO Hostname that would be awesome. This can be found in the about section of the NEEO app.

      Thanks!

      Like
  • I have the same issue aswell. After a while the brain starts blinking white. Updated to the newest firmware without that helping.

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Geir Boee Does you also have a reserved IP address for your NEEO?

      Like
      • Geir Boee
      • Geir_Boee
      • 2 yrs ago
      • Reported - view

      Jeff no

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Geir Boee Have you attempted to reboot your NEEO Brain and router? What about a data reset?

      Thanks!

      Like
      • Geir Boee
      • Geir_Boee
      • 2 yrs ago
      • Reported - view

      Jeff  Yes indeed (by your suggestion on the support case). lets try to fix it there.

      Like
  • Jeff

     

    Any suggestions?  Thanks.

    Like
  • Same issue here. :( My brain is also blinking a couple of times a day. While this is the case, the remote nor the app can be used to control anything. Switch off/on the brain mostly helps, but I don't like to stand up, every time I'd like to use the Remote. :(

    I do also have DHCP (with a reserved IP for the Brain) in use and a connected LAN Cable - I have no idea, why the brain tries to use WiFi instead..!? That doesn't make any sense IMHO. We all know, that WiFi isn't very reliable.

    Is there anything we can do about this? (Besides removing the assigned IP?)

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Tetrikus Can you DM me your NEEO hostname which can be found in the about section of the NEEO app?

      Can you remove the NEEO from the DHCP reservation list? This is a great step for testing to help isolate the issue.

      Thanks,

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Tetrikus Hello! Just wanted to circle back to this. Not too sure if you saw my last response :).

      Thanks!

      Like
  • Hi,

    Always have this problem of loosing connection everyday.

    The brain led is not blinking, I need to power off the brain to working again.

    Sometimes I need to power off the brain et restart the remote.

    Can you help me please ?

    Like
  • Hi,

     

    I fix all IP but always the same problem.

    But when I only reboot my internet box all is working again.

    Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 1 yr ago
      • Reported - view

      Marc DILLINGER Hi Marc, thanks for posting this. Can you provide me with your NEEOs hostname? This can be found in the about section under settings.

      Also, how far would say your router is from your NEEO Brain and remote? Are they on the same floor or perhaps on different floors?

      Thanks!

      Like
Like Follow