Neeo remote will not pair with Brain over Wifi

mike.ruiz@outlook.com

Sep 3, 16:19 PDT 

Hello, 

I have tried every step listed on your site for troubleshooting the Neeo remote and it still will not pair after multiple attempts. Including unplugging the Brain and restarting the router.

The remote will always stop at the WiFi connecting step than pop up the "Oh No! Failed to connect to WiFi" message—See attached video. The Brain is within inches of my router and I've gone as far as to lay the remote on top if the Brain and router on a few attempts when trying to pair.

This unit is brand new out of the box, so I don't believe it's been damaged in any way. The only thing I can think of is that the Brain updated it's firmware before to the most current version before I tried to pair the remote. To which I did a factory refresh on the Brain and still have the same issues after starting over again. 

The app on my iPhone 6 works perfectly with the Brain unit for controlling devices and adding new ones, but I did not get a Neeo to have it only be able to work by using it with my phone. 

If it helps you troubleshoot, here are my router/wifi settings - 

NetGear Nighthawk X10 R9000
Wireless Network (2.4GHz b/g/n)
WPA2-PSK [AES]

Thank you.

Reply
17replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi, Mike Ruiz. Thank you for reporting this. I'm very sorry to hear about that.  Could you please try to connect your NEEO Brain directly to your router via Ethernet and perform the Wifi settings on your NEEO app once more, if you haven't already done so. 

    Please make sure your mobile phone and your NEEO Brain are on the same network. (2.4Ghz) You can also try to log into your router and change your 2.4Ghz wireless channel to 1, 6 or 11.

    If the above steps do not help to successfully pair with the NEEO Brain, please try recovery of the NEEO Remote by following these steps:

    1. Hold the power button on the NEEO Remote for 15 seconds
    2. Wait a few seconds
    3. Press the power & mute button simultaneously for a few seconds
    4. You should see the option for recovery, follow the on-screen steps
    Like
      • Mike Ruiz
      • Mike_Ruiz
      • 3 yrs ago
      • Reported - view

      Ingrid Hi Ingrid, thank you for the suggestions. Unfortunately, I have already done everything you've recommended multiple times already and still get the "Oh No" message from the remote when trying to pair. From what I can tell, this reset/reboot process seems to be the only troubleshooting advice available, since it's been given by every person I've contacted on the Neeo support team. 

      Remote tech support can't be easy and I do appreciate the help. Please let me know if there are more suggestions for solving the pairing issue. At this point is seems that the problem lies with either the software or it may be a hardware problem with the Brain or remote itself.

      Like
  • Mike Ruiz said:
    NetGear Nighthawk X10 R9000

    What bandwidth is set for the Nighthawk?
    I had some problems with "Full Speed" being set to the Nighthawk.

    Could you try lowering the network speed on the router and try again?

    once it is connected, you can change the speed again.

    Like
      • Mike Ruiz
      • Mike_Ruiz
      • 3 yrs ago
      • Reported - view

      nuro Hi Nuro, thanks for the suggestion. My router default setting is "Up to 800 Mbps".

      For the test I knocked it back to 54 then 347, doing a power down of the router and brain then resetting the wifi password of the brain before doing a restore of the remote before pairing for each bandwidth setting. Unfortunately, the remote still gives the "Oh No" message and will not pair. Attached is a screen grab of all the bandwidth settings available for the router. 

      Thank you for the help and let me know if there are more suggestions for solving the pairing issue. At this point is seems that the problem lies with either the software or it may be a hardware problem with the Brain or remote itself.

      Like
    • Mike Ruiz that sounds not to good to me.

      i have no further ideas for that.

      i think you should try the way Ingrid had mentoined.

      Like
  • Mike Ruiz Could you please post pictures with debug mode enabled? To enter debug mode, please press the menu button and the channel down button repeatedly until you can see the logs on the remote screen. After that, please press also "Try again" while you are in debug mode. Our developers will look into this. Thank you very much! 

    Like
  • Hi Ingrid , thanks for following up. 

    Please see below for some screenshots of the remote in debug mode. Hopefully, you'll be able to see where things aren't working and be able to offer some more help. If there is anything else I can help you with, let me know, I'd love to get everything working properly. Thanks. 

    Like
  • Mike Ruiz Thanks for all the images. I have forwarded this to the developers. Just to be sure, could you please let me know which firmware version is on your NEEO remote? You can find this in the Hamburger menu in the upper right corner of your NEEO remote.

    Did you also try to set the wireless channel to 6?

    Like
      • Mike Ruiz
      • Mike_Ruiz
      • 3 yrs ago
      • Reported - view

      Ingrid Hi Ingrid, just to be thorough, I set my router channel to 6 and then did the whole reset process again:

      - powered down my modem, router, brain, and remote
      - powered on modem, waited until internet was back on
      - powered on router, waited until wifi signal was broadcasting 
      - powered on brain with an ethernet cable plugged in
      - reset wifi password on brain through Neeo iPhone app
      - powered on remote by holding "power" and "mute"
      - selected "menu" to do a full restore on remote
      - remote failed to connect to wifi, "Oh no!" message

      Attached is a screenshot of the About menu on the remote after completing that process and the firmware details on the brain from the Neeo app. I also ran some diagnostics in what my router was up to throughout the process. I don't know if may help, but take a look just in case it could be useful. 

      Thanks again for your help with this, I would love to get this all up and running at some point soon. 

      Like
  • I had similar issue setting mine up and after some troubleshooting realized I needed to allow broadcast/multicast traffic from both the brain and remote. My WiFI is using Unifi hardware so I’m not sure this applies to the nighthawk but it might be worth looking into. 

    Like
      • Mike Ruiz
      • Mike_Ruiz
      • 3 yrs ago
      • Reported - view

      Thanks David kopack  I'll look into that. I'm not familiar with broadcast/multicast, but a search came up with it having something to do with the Disable IGMP Proxying (on by default) setting option on my router. I have no idea what that means or what it would do if i changed it to off.

      I'll search around some more, but I'm interested in what led you to finding that as the solution. 

      Like
  • Mike Ruiz Hi, thanks for all the additional information and for trying all these steps again. One reason could be that there are large numbers of AP around. Could you also send us a screenshot of the wifi analyzer, ordered by signal strength? Which wifi analyzer program did you use?

    Could you also try to change the channel width to 20MHz and place the NEEO remote very close to the router? 

    You can also try to set up a separate SSID for the NEEO brain and NEEO remote
    If you have a cheap low-end router, try to set up a dedicated AP on the router just for the NEEO brain and NEEO remote.

    Please note that you don't have to change this setup permanently, it’s only to help the devs figure out where the issue is.

    Like
  • One of the images shows he is using VPN and the battery is too low!

    Please don't hold me on this but check!

     

    Eman.

    Like
  • Hi,  Mike Ruiz. I'd like to follow up if this is solved and you were finally able to pair your NEEO Remote? 

    Like
  • Hi Ingrid , thank you for following up. To be honest, I've given up with trying to get the remote to work. It's clear that there is no real solution to be offered from Neeo, which is frustrating. Especially for a product that is marketed as something that should "just work" out of the box.

    Additionally, your Head of Customer Experience, Jeff Zavala refuses to acknowledge that the issue may be with the hardware or software of the remote, stating that it has to be my router. With the amount of trouble shooting I've had to do to try and get the remote to pair, it's obvious that this is not an issue with my router, as every other wireless device I have connects to it works seamlessly and without issue. 

    If at some point a solve or update does come in that will allow the remote to properly pair, please let me know. I'd love to get things working. Unfortunately until then, I can't stand behind this purchase and am extremely disappointed that for something so expensive, it's nothing more than a paperweight at this point. 

    Like
  • Hi Ingrid

    Thank you so much for sticking with this. 

    I’m happy to tell you that Jeff Zavala, NEEO Head of Customer Experience had an idea about double checking for a blank space after the SSID, and it was just the thing to solve my pairing issue. After checking my router settings and removing the extra space, my remote paired perfectly.

    Just to check, I tried a couple things and it turns out that the remote will not pair at all if there is a blank anywhere in the SSID, for example if the Wi-Fi Network is two words with a space in the middle. This is a great tip for anyone trying to do some setup troubleshooting!

    I appreciate all the help in trying to solve the issue and hopefully, everything should be good from here on. 

    Now that the remote is operating, one question. I have my NEEO set up with my Xfinity cable box. Is there a way to enable the number pad to be alphanumeric? My cable service allows me to search by show title but without characters under the numbers, it’s a little difficult to keep guessing. If there’s a setting that I missed to turn this on, please let me know. 

    Thanks again!

    - Mike

    Like
  • Hi,  Mike Ruiz. Thank you very much for your feedback! I'm very glad to hear that! 🙂

    Is there a way to enable the number pad to be alphanumeric? My cable service allows me to search by show title but without characters under the numbers, it’s a little difficult to keep guessing. If there’s a setting that I missed to turn this on, please let me know. 

    Don't worry, you didn't miss it. 😉 This option is not available yet, though there is already this voting in the Idea Voting section. Please vote for this as well to give this higher priority for next firmware releases. Thank you very much! 

    Like
Like1 Follow