Can’t connect to Brain

Sometimes I grab the remote and it is unable to connect to the brain. Is there any reason why? Can this be worked on in an upcoming update? I usually fix it by restarting the remote, but I also wonder if I just let it sit for a few minutes and retry to connect again.

Reply
24replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Chad L. What Firmware are you running on the Brain and on the Remote?

    Is NEEO Link enabled? Does the App work, when the remote does not?

    did you see this Topic? https://planet.neeo.com/r/k9k85h

    There the trouble was nearly teh same, maybe it also applies to you. If you check that, and if it not helped, just reply and we can check and look at you individual issue.

    Like
  • Thanks Markus, I do have NEEO Link enabled. And I hadvnt checked recently but I believe my phone app does work when the remote couldn’t connect. Should I disable the NEEO Link? 

    My firmware appears to be the latest release, I have been checking every couple days for updates. I do have a ton of electronic devices throughout the house. I even still have some sort of frequency issue with a WiFi aquarium pump that I can’t seem to figure out now that you mention it. I’ll look into some frequency changes across a couple devices and see if that helps.

    Thanks 

    Like
    • Chad L. what else is important: is your brain wired and wifi connected or just wifi?

      NEEO Link disable doesn't work after the first enable (it actually never gets switched off completly)

      Like
  • My Brain is hard wired, would it be better to unplug the Ethernet then? I just switched my router frequency from 8 to 11. Will see how that works as well. Also, I haven’t setup my 2nd NEEO up yet, but am planning to this weekend. Currently the brain and 1st remote are for the living room. The 2nd brain and remote will be setup in the master bedroom. Is there anything else I should be aware of?

    Thanks for following up.

    Like
  • It doesn’t seem like im aloud to have 2 NEEO setups in our house. Every time I grab the bedroom remote I have to change brain to connect to the bedroom brain again. Then when I get back out to the living room I have to repair the living room remote and brain. Then back to the bedroom and I need to repair again. I’ve confirmed both remotes and brains are using the latest firmware update then I’ve also change my router to channel 11. I also disable the NEEO Link even though you said it will never really turn off now. Any other thoughts? 

    Like
  • Also forgot to add that I am able to connect just fine with the app, it’s just the remotes that won’t connect to the brains. Both Brains are hardwired to my router and most of my devices are setup on the 5ghz channel (app access is via 5ghz) meanwhile I know the NEEO remotes are only 2.4ghz. 

    Like
  • Chad L. a flawless sync between the usage of multiple brains is not possible with the current firmware release, this feature will come!

    For your issue with the Network, did you provide a separate name for your 5GHz and you 2,4GHz network or did you use the same SSID name? If you use the same name, can you change the 2,4GHz and reconnect your brain and let the remote update the wifi settings?

    Like
  • Yes, I’ve got 2 different WiFi network names. It never fails. I’ve got to reconnect and repair every time. I’m thinking about unplugging the ethernet from both brains, I’ll try that and let you know. Any other thoughts in the meantime?

    Like
  • I can’t figure it out, I unplugged the Ethernet on both of the brains and couldn’t connect either remote after multiple tries. Then I tried the app on my iPad. Switched the iPad to the 2.4ghz band just to stay on the same band.

    After several attempts, the app wouldn’t connect. So I unplugged power to the brains, and reconnected Ethernet to the living room brain. Plugged power back in, after the light stopped blinking I tried to connect and it still wouldn’t connect the first few attempts. Finally on the 3rd or 4th attempt the app actually connected to the bedroom brain (wireless). I reset the WiFi on it just to be safe then tried to find the living room brain. After searching a little bit it was able to find both brains this time (there must be a decent delay after the light stops blinking and stays solid before the brain connects to WiFi). I then connected to the living room brain and reset the WiFi on the living room brain as well. 

    I then tried to reconnect the living room remote and the first attempt was not successful, but the 2nd attempt did connect.  I’m tired of messing with it for the day and will just turn off the bedroom remote, I’ll try to connect it tomorrow and see what happens. Anyone else having this trouble and figure out what’s going on? 

    Thx

    Like
    • Chad L. I don't have future ideas. ALso i only know, that Niels de Klerk have more then one Brain and remote up and running. Besides the NEEO Team, i don't know any other. But never heard of such big troubles. Maybe he has a idea. Else you need to wait for Patrick or Raphael to jump in and help.

      Like
    • Chad L. There have been quite some improvements to WiFi between the shipped firmware and the latest greatest. My first advice would be to setup one brain and one remote and update them both to the latest firmware. If this went all fine then install the second combo, and upgrade as well. (Maybe even cable connected)

      in the app you can go to settings-> NEEO Brain->change brain to let the app connect to a different brain. This way you can setup your second brain and or switch to the first. 

       

      Common wifi issues could be. Seperate SSID for 2.4 and 5ghz radios that land on a seperate IP network.

      some WiFi solutions actively block multicast or specifically multicast DNS. Either because of a feature or a bug in the WiFi device. To check if this applies to your WiFi device it’s best to google the WiFi brand and type including “multicast” or “MDNS” or “bonjour” . Bonjour is an apple term for MDNS which is multicast based. Neeo uses MDNS to advertise the brain services.

      hope this helps you a bit further.

      Like
  • Thanks Niels, I think I may have found something on my ASUS router. I’m not familiar with multicast settings though. Would you mind taking a look at the screenshot below. Should I enable one of these or both of these? Or do you think it could be something else even? Also, I don’t think I’m getting different IP addresses, but I’m not exactly sure how to very either. I appreciate any help you can give. Thx

    Like
    • Chad L. i would try enabling IGMP Proxy first and test the app and remote.. Then test using IGMP PROXY and IGMP Snooping. Depending how your network equipment is working with these features you might have some succes with these features.

      Like
  • Hey Niels, I tried enabling the IGMP a proxy first and continued to have trouble, so I enabled the IGMP Snooping and also had some trouble connecting. I then rebooted my router just to be safe, no success yet. I ended up doing a reboot on the living room remote first and when it turned back on it synced right up to the brain with no trouble. So I went to the bedroom and rebooted it as well. It synced up with the bedroom brain and I’m up and running with both remotes for the first time. So far so good! Thanks for all the help.

    I sure am looking forward to the next firmware update. 

    Like
    • Chad L. sometimes a solution is more simple than anticipated. I’m wondering if the multicast changes did the trick or all it needed was a reboot. Are you willing to do some more tests? I think it could help others in the future.

      Like 1
  • I am glad  Niels de Klerk was able to help. Really interesting information here, I need to remember that, I guess this could help a lot of other users too.

    Like
    • Patrick I’m not so sure yet that the multicast changes made it work. As far as I can tell, the remote and the app uses multicast to detect the brain. On some WiFi routers and access points multicast is blocked or not handled without these features turned on. Typically the same equipment would have issues with some apple protocols, which is more easy to find a solution to as there are more apple users then NEEO users (at this point, 😜) the issue would be bonjour/ MDNS

      Like
      • Patrick
      • Patrick
      • 4 yrs ago
      • Reported - view

      Niels de Klerk This thread is becoming very interesting, I will forward that information to our developers to check if there is anything else which we can improve on our side.

      Like
      • Chad L.
      • Chad_L
      • 4 yrs ago
      • 1
      • Reported - view

      Niels de Klerk I was thinking he same thing. I’ll run a couple more tests this weekend and let you know what I find. 

      Like 1
    • Patrick I believe that using multicast is the best way of discovery in a home network environment. With IGMP, multicast can cross broadcast domains (L2 boundary). Only thing is that you must be aware that in some occasions it could be blocked on WiFi routers and access points. The given search parameters will find a solution to these issues if there are any. With all the apple devices out there, the default configuration of the equipment is normally working.

      Like 1
  • Well, I had a fun time this weekend tryin to decipher whether IGMP Proxy or IGMP Snooping helps my remotes work or if it’s a simple reboot. The answer is that I still don’t know. I did figure out however that my router had some internal issues I couldn’t figure out. This may be the cause with all my issues from the start. After messing with the router last week, changing channel frequency, enabling IGMP Multicasting options, etc I lost accessibility of my Nest Cameras within the House, oddly, I learned yesterday I could view them via LTE on my phone. I also had more trouble with some remote access software. When I started to disable the multicast setting to tinker I couldn’t get the bedroom remote to pair at all. 

    Because i’d been having other trouble as well I decided to reset the router to its default setting and start over. This solved all my problems. But I was tired of messing with it so I just enabled both IGMP Proxy and IGMP Snooping. I had to re-pair both remotes and they didn’t immediately work. So I rebooted each after the first pair came up unsuccessful and they pair correctly upon boot up. 

    Like
    • Chad L. thanks for all the efforts. 

      Like
      • Patrick
      • Patrick
      • 4 yrs ago
      • Reported - view

      Chad L. Glad you are finally up and running. Thanks for posting all that information, I am sure this will help us in future support cases 👍

      Like
  • After a disconnected remote I could not reconnect to the brain. 

    What I did to solve the problem:

    1 - power of remote

    2 - power and back button 

    3 - power on remote: pair With brain. Sidd WiFi is found but could not connect.

    4 - in iPhone APP reconnect WiFi and set password WiFi in the brain settings

    5 - reconnect remote: now remote is live again!

    Brain was already restarted before.

    Like
Like Follow