Remote turning off and failing to reboot

My remote (a black cat) for the past few weeks has been misbehaving.

the screen goes black, the remote is unresponsive and appears to have shut down on its own. If I press power button to reboot it, the Neeo logo and the spinner comes up, but in the middle of the reboot process the screen goes black again and the remote has shut off again. If I try to reboot again the same happens, until maybe 1 attempt in 5 the reboot process completes and the remote works again for a while. I thought it was a battery problem, but when I put the remote on the charger, the battery logo shows always more than half charge

I tried a complete reboot by holding the power button for 15 sec and then 3 sec to restart, still same problem. I tried to refresh the firmware power btn+mute, flash went ok but problem still persist.

Any suggestions?



18replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Patrick

    maybe related to this:

    However my problem started way after the last update.

  • Claudio Guareschi. Thank you for reporting this. Could you please check which firmware are you running on your NEEO Brain and NEEO Remote? Did you also try to reboot your NEEO Brain? If that doesn't help, I would suggest performing recovery on the NEEO remote. To do so, please follow these steps:

    1. Hold the power button on the NEEO Remote for 15 seconds 

    2. Wait a few seconds 

    3. Press the power & mute button simultaneously for a few seconds 

    4. You should see the option for recovery, follow the on-screen steps

    Please keep me updated. 

    • Ingrid 

      Hello Ingrid, and thank you for your answer, 

      Remote fw is N:0506 R:114 B:112

      Brain fw is 0.50.6-20180424-481315c-0523-151625


      Rebooted brain and remote several times with no changes

      Done the recover procedure with no changes.

      My feeling is it is a problem with the battery based on these observations:

      I will refer to battery indicator for the white little battery on the upper left corner of the remote shown during normal use. charging indicator for the big green battery displayed with the remote on the charger

      The battery and the charging indicator are all over the place. This is what I see: I may have a full battery on the battery indicator still the remote may shut off and be unable to complete reboot. If it does that, and I place the remote on the charger the battery charging indicator may show half full when a few seconds before the battery indicator was completely full. If I leave the remote for 24h on the charger untouched, I get a full charge indicator and it usually doesn't shut off (i.e works ok) for 7-10 hours of normal use, then starts the shut off-fail reboot thing again. This is best I can reproduce the problem and it happens over and over again. Prior to all this happening, I was getting more than 48h on a full charge with my typical use of the remote. This is why I think it is a battery problem, maybe a cell went bad. Please note what I describe as shut off is the remote turning suddenly off.

      Hope this helps

    • Claudio Guareschi Thank you for trying the recovery and your detailed feedback. That helps us a lot. Then, I think it's the best to get in touch with our support team as they handle replacements. Please write a message to with all your details. It would be very welcome if you could include a short description of when your NEEO Remote starts to have this issue. After a firmware update, while using it or while charging,...? Thank you. 

    •  Ingrid 

      Hello Ingrid, I emailed support as you suggested, Jeff contacted me promptly on 8/6 asking for the need host name and where it was purchased. I supplied that info bit haven't heard from Jeff since. I emailed back Jeff supplying the info again but I got no answer. What should I do?



    • Hi, Claudio Guareschi. Thank you for getting back to me. I will check with the team immediately and come back to you shortly. 

  • Hello NEEO team !

    Seems experience a similar issue with my black cat :(
    Current Firmware: 0.51.13-4f47f9b

    Screen stay blocked on the Neeo logo and the spinner.

    If I try to reboot, the same happens...
    If i try recovery, the same happens... (screen stay blocked on resetting factory settings)

    Ingrid Any suggestions?

    Best regards,


    • Hi,  Jean-christophe Vermandé. Thank you very much for reporting this! Could you please send an e-mail to with your shipping details and a link to this message? 

      Like 1
    • Hi, Ingrid . Thank you very much, I just sent the email.

    • Ingrid , sorry to ask you but is it possible to have information, I have no return to my email :(

      Every day the remote is down, turned off or blocked on neeo start screen, it is very frustrating

      Every day, I have to make a "recovery" that always blocks on the "reset" screen and then reinstall the firmware then put the remote on the charging base and cross your fingers to get to the configuration screen ... 3 times out of 4 this remains stuck on the startup screen.

      Could you help me ?

      Best regards.

    • Hi, Jean-christophe Vermandé. I'm very sorry that you didn't receive a response to your e-mail. I'll check the status with the support team. 

    • Ingrid , Thank you very much for your answer.

      I was in contact with Jose from Neeo support on December 19th and since then nothing more ...

  • HI NEEO team.

    unfortunately I have the exact same problems with my black cat, I have tried to do everything mentioned above, nothing works.

    firmware is up to date, can you please help me..? 

    Best Regards, Michael 

  • @Ingrid Patrick   I have the exact same problem for the last 2 months. 

    Is there any help out there?

  • Seems we are having the same issue now, did anyone get theirs sorted?

Like Follow