Black-cat NEEO not Powering On

I have tried everything. Press power button for 10 sec, and again, putting the remote back in the cradle, swapping power cables, etc. I can control my devices via my iPhone, but the remote is dead.

Reply
5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Jeff should be able to help you getting your unit up and runnign again! Best would be to write a mail to support@neeo.com and provide a link to this topic!

    Like 1
  • Hey  Omer Salom Thanks for reaching out and sorry to hear your NEEO Remote is unresponsive. If you can please email support@neeo.com , I am sure we can get your remote going and if not replaced!

    Thank you  Markus Mahr for tagging me :)

    Like
    • Jeff 

      Hi. and thanks for your help.

      Tried it several times but the remote won’t power on again.

      What’s the next step?

      Thanks in advance,

      Omer

      Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 2 yrs ago
      • Reported - view

      Omer Salom 

      Thanks for the update. Can you email support@neeo.com and we can get a replacement NEEO Remote going asap!

      Thanks!

      Like
  • Reading through the forums, this seems to be a common issue with the black cat remotes. And alas, mine has also carked it - the remote just doesn’t turn on. I’ll email support too. 

    Like
Like Follow