Can‘t add device Apple TV 4K

Hi,

i just got an Apple TV 4K that replaces my aged Apple TV 2. So I removed the Apple TV from my Neeo device list and tried to re-add something like Apple TV 4/4K. However, in the Neeo „add device“ nothing from Apple is found.

If I remember correctly in the initial setup there were several ATV generations in the device list. What coul be wrong here?

Best regards,

Bernd-Christoph

Reply
3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Bernd-Christoph Schwede These can be two issues:

    1. The Cloud Servers were updated in the time you try to search for the device.

    2. Your brain can have issues with the Devicesearch.

    Try a reboot by just unplug the Power, wait for 5 seconds and replug it. The 5 Generations of AppleTVs are there for sure!

    Like 1
  • 👍🏻 works now, thx!

    Like 1
    • Bernd-Christoph Schwede Thank you for your feedback. Please let me know if you have questions. I will now mark this thread as solved. Regards,

      Markus Mahr Thank you for your post. Regards,

      Like
Like Follow