Unable to create account (ios11b10)

I keep getting the error message “Could not signup”

Tried multiple email addresses.  Any ideas?

Reply
18replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Ticket 15205

    Like
  • Same problem here today. Also notice that in the Create Account wizard there is no attempt to confirm the entered password with a second entry. Any typo not noticed by the user will result in a PW they don't expect.

    Like 2
  • Did you manage to sign up yet? On what exact device with what version are you trying? If you still have that problem, send me a message and I will try to help you get that solved quickly.

    Like
  • It was on the iPhone 6s. Eventually came back to it, still wasn't working, so I closed the app, re-opened and retried. Went through fine. Funny thing, after all this time (I sponsored in 2015) I'd forgotten that I had opted for the Brain only. Imagine my disappointment when I opened the beautiful box to see an empty recess where the remote should be!

    Like
      • David Hall
      • David_Hall
      • 2 yrs ago
      • 2
      • Reported - view

      David Roady buy the remote. Currently it's much more beautiful but much less functional than Logitech. But clearly it won't be too long....

       

      And the remote is really the best bit !

      Like 2
  • Same problem here, tried from Android and from iPhone.. no luck. Ticket 18007.

    Like
  • same here, have been trying for hours 😓

    Like
      • Patrick@NEEO
      • Community Manager
      • Patrick
      • 2 yrs ago
      • Reported - view

      Nick Could you try to reboot the NEEO Brain by simply unplugging it? Was your WiFi connection successful? 

      Like
      • Nick
      • Nick.2
      • 2 yrs ago
      • Reported - view

      Patrick heya, just tried that, still the same though :(

      Like
      • Nick
      • Nick.2
      • 2 yrs ago
      • Reported - view

       Patrick is there a way to reset the neeo brain?

      Like
      • Nick
      • Nick.2
      • 2 yrs ago
      • Reported - view

      Patrick ah and yes wifi was successful

      Like
  • i solved it :) 

    Like
    • Nick Will you be so kind to share your solution ? Thank you !

      Like
      • Nick
      • Nick.2
      • 2 yrs ago
      • Reported - view

      Alessandro Dellavedova  my router was the problem, he was blocking the traffic for some reason 

      Like
      • Patrick@NEEO
      • Community Manager
      • Patrick
      • 2 yrs ago
      • Reported - view

      Alessandro Dellavedova Have you created your account? Otherwise, send me a PM.

      Like
      • Patrick@NEEO
      • Community Manager
      • Patrick
      • 2 yrs ago
      • Reported - view

      Nick Just out of interest for other support cases, what settings did you have to change on your router?

      Like
      • Nick
      • Nick.2
      • 2 yrs ago
      • Reported - view

      Patrick basically, it was my own stupidity, i have mac whitelisting and somehow it did not apply properly at first

      Like
    • Patrick I tried yesterday and it worked. Thank you for your followup.

      Like
Like4 Follow