Neeo remote is completely dead

After the first couple of days, the remote will not work nor even turn on. I can't get it to work at all.  

Reply
28replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Tony Kim

    Most likely stating the obvious, but is the remote fully charged? If so, try to hold the power button for a while.

    Like
  • I'm experiencing the same thing.  Brain did an update today successfully and the remote is dead.  Its been plugged in for 4 days (while I was at CEDIA) and now the remote won't turn on.  I've double checked the power outlet and even trying another now.  The remote will not turn on.  I really hope this isn't a boat anchor before I even program all my devices in it.  #havehighhopes

    Like 1
  • Come on....  of course I powered it.  I also tried pressing buttons etc etc. nothing works. Also nothing on support site to give you any kind of troubleshooting instructions 

    Like
  • Could you quickly try keeping the power button on the NEEO Remote pressed for ten seconds, and then shortly press it again until it starts booting? I will be checking your logs as quick as I can. 

    Keeping the button pressed for ten seconds does a power cut. 

    Has the remote been charging before when it was still running? Just want to make sure it was actually getting power. 

    Like
      • Tony Kim
      • Tony_Kim
      • 2 yrs ago
      • Reported - view

      Patrick 

      Like
      • Tony Kim
      • Tony_Kim
      • 2 yrs ago
      • Reported - view

      Tony Kim I tried that. Doesn't work.  Nothing. Doesn't start up any more. Completely dead. 

      Like
  • Hello Patrick, I just tried the 10 seconds and short presses thereafter while on the charger and I've got no response.

    Like
    • Kevin Magna i just did it - hold power for 10 seconds then keep pressing power over and over  - mine turned on!

      Like
  • I am experiencing the same problem with my remote also. After the brain updated I put it on the charger and when I went to use it today nothing.

    Like
  • Could you try using the charger and cable of the NEEO Brain? Just want to make sure it is actually getting power. 

    Like
  • I switched power sources and it responded by actually showing the battery was at 100%

    Like
  • Now it’s waiting to connect to the brain 

    Like
  • It’s alive!

    Like
  • Craig Garrett Good to hear that, even though I do not really have an explanation for that behavior right now. 

    Now let's try getting the others up and running too. 

    Like
  • Kevin Magna Can you try the same thing a gain while not having the NEEO Remote in the dock? 

    Like
  • I've done the power supply switch and still no response from the remote

    Like
  • I assume the NEEO Brain booted, so both power supplies are OK, right? Is the NEEO Brain working when controlled by the app?

    Can you try the power cut again while not having the NEEO Remote in the dock? 

    Like
  • yes app control has been fine, it does crash more than expected.  The remote, off the charging cradle is now powered on and showing 100% battery life.  Is the remote suppose to work in the cradle?  That appears to be the issue.  Its even downloading an update and rebooting, successfully.

    Like
    • Patrick looks like we're back up and running.  Let me know what the expected use case is when the remote is in the charger when you have time, not urgent, more curious.

      I look forward to getting more of my devices synced up and Neeo continues to evolve to market demand.

      Like
  • I had the same issue the day after I received my Neeo.  Holding the power button fixed the issue and I have not seen it come back.

    Like
  • On the NEEO remote, press and hold the physical Menu and Power keys concurrently until the remote reboots.  Similar to how you restart an iPhone.  

    Like
  • Patrick I had the same issue. Did the power button trick and it came back on. First it showed a battery charging for a few seconds. Then it went into updating the boot loader and then followed by a firmware upgrade.  I have no idea why or whats going on but it appears to be fixing itself. I was like the others, I had not used it for a few days after receiving it and setting it up. Battery was 100% when I left it. Growing pains I'm guessing. I thought it was kaput. 

    Like
  • Glad to hear it is not kaput 😉 I have forwarded the issue to our developers and test engineers, to actually figure out the root cause of this will need in depth.

    Like 1
  • Same issue here.. have received the remote today, but it does nothing at all. Holding power does not help. Holding Power/Menu does not help. Both chargers do boot the brain. But the remote does stay black. The first time I put it in the charger, the neeo logo was displayed for less then a second, then it went black and nothing happened.. :(

    Like
      • Pascal@NEEO
      • Test Engineer
      • Pascal
      • 2 yrs ago
      • Reported - view

      Markus Strässle Hey Markus, can you leave the remote in the dock until tomorrow and try again? Thanks

      Like
      • Tetrikus
      • Tetrikus
      • 2 yrs ago
      • Reported - view

      Thanks Pascal - I left it in the dock until today morning and shortly tried it again. Nothing. I haven't had the chance to spend too much time with it, but I tried the 10-Seconds Power and Power again. Nothing happened. Is there anything else I could try besides the long Power-Press? I've seen some users which talk about Power/Menu and so on.

      Like
  • I am afraid having the same issue. Installed it over the weekend, used the remote for maximum two days during the config last Monday was away for couple of days and now the remote is dead. Tried all the above, both chargers work with brain, pressing power/menu etc... nothing 

    Like
    • Jacques So, did you allready try a force reboot of the remote? If the remote stands in the charger there can be a Bug that shut the Display to black. Please try the following:

      Hold the Power button for 10 seconds, then release it and shortly press it again, this should boot the remote from scratch. If you don't see a Picture after that, you may have an other issue. Then you can try the same, when the remote is in the loading dock.

      Like
Like Follow