NEEO Remote Unable to Connect

I recently moved and had my NEEO brain and remote unplugged and disconnected for about a month.  When I plugged everything back in, the brain works great, the remote boots up, but cannot maintain a connection.  I have restored my brain, I have reconnected the remote (probably 30 times).  Each time, it finds the brain but then cannot keep a connection to load the interface.  I have prioritized NEEO Link to avoid any possible issues with wifi, but still it persists.  My brain is hardwired and I have no issues with other wifi devices in the house.  Any thoughts on what I can do next?  I would love to be able to use my NEEO again!

Reply
61replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Travis Hamill. Hi, thank you for reporting this. Are you able to control your NEEO Brain with the NEEO app? At the moment we recommend to keep this prioritization off.  Please also see Raphael's answer here

    If WiFi is not yet working, can you please reboot your router once? When its back online please connect the NEEO Brain via ethernet, open settings in the NEEO App, tap on "NEEO Brain" and perform the Wifi setup once more. 

    Once the Wifi is up, let's repair your NEEO Remote to make sure it gets the latest WiFi settings from the NEEO Brain.  

    1. Turn off the NEEO Remote
    2. Then press the power button on the NEEO Remote as well as the back button at the same time until your NEEO Remote ends up on the screen which has the test "Hi! Nice to meet you." and the button "GET STARTED" on the screen.
    3. Follow the instructions to pair your NEEO Remote to the NEEO Brain again

    Please keep me updated if this can solve it. 

    Reply Like 1
      • Bryan West
      • Bryan_West
      • 4 mths ago
      • Reported - view

      Ingrid 

      I’m having the same problem, and I have restarted the brain and the remote Countless times following the instructions above. The remote consistently says that it is unable to upload assets.

      Reply Like
    • Hi,  Bryan West. Thank you for your feedback. So, do I understand correctly that you also have this issue since you moved? Could you provide me with the manufacturer and model number of your router? 

      Did you also try to reboot your router? (all steps as above) 

      Which firmware are you running on your NEEO Brain and your NEEO Remote? Did you recently add a device? 

      Can you also provide me with your NEEO hostname which can be found in the NEEO app settings under the about section? I will forward it to the dev team to check it out. Thanks. 

      Reply Like
    • Ingrid I have mostly resolved the issue with my NEEO.  Turns out there was some type of network isolation happening as the NEEO brain was on wired network and the remote was on WiFi.  Once I disconnected the Brain I was able to make a connection.  Is it possible that the remote is getting confused as to the IP Address to use for the brain since it will be assigned one for each the wired connection and one for the WiFi one?  This does appear to be an intermittent fix as the remote has lost connection to the brain several times since, but at least it now works most of the time.  Since you asked Bryan West , I am using an Asus AC3100 router.  NEEO does appear to work better with the Merlin firmware than with the stock firmware.

      Reply Like
    • Travis Hamill probably you have an option in your wireless router related to multicast or mdns that’s blocking this traffic. Apple names it bonjour, may help to find a solution.

      Reply Like 1
    • Travis Hamill 

       I have mostly resolved the issue with my NEEO.

      Most of the time? Actually, it should work all the time. With the next firmware release, there are also some improvements for the NEEO Remote. 🙂 Do you need further help at the moment?

      Is it possible that the remote is getting confused as to the IP Address to use for the brain since it will be assigned one for each the wired connection and one for the WiFi one?

      That sounds weird. That shouldn't have any impact on the Remote. 

      Thank you very much for the router information. It helps our developers a lot to get additional information. 

      Reply Like
    • Ingrid Niels de Klerk , I think I'm reasonably okay at the moment.  I am still having issues with the connection every few days and I suspect that it may be related to group key rotation in my router and the brain or the remote not correctly registering.  I have been playing around with my multicast settings but am unable to completely turn it off.  I did enable IGMP snooping in hopes that the router would recognize NEEO as needing to be a recipient of multicast packets, but it has yet to fully resolve the issue.  As a result, I'm starting to think that there may be some further development from NEEO necessary to avoid issues with high-bandwidth wireless AC (or newer) networks leveraging multicast.  I'll be excited to see the next firmware update!  I will also try some of the steps that were recommended for Bryan.

      Reply Like
    • Travis Hamill mDNS uses a TTL of 1. So i don’t believe IGMP will help. The packet will never pass a routed interface by design. With that I meant the way mDNS is designed. Some access points are able to “bridge” or “proxy” these packets. Luckily everything brand give it a different name making it terrible to find. Lol.

      best is to google for Apple issues (iTunes, discovery, bonjour or HomeKit) issues on the AP/Router brand as these are most commonly documented and all because of mDNS.

      hope this helps a bit.

      Reply Like
    • Niels de Klerk This certainly gives me more to play around with... too bad I'm at work right now and can't start monkeying around with settings immediately.  I'd be willing to bet that this gives me enough traction to figure it out though!  Thanks much!

      Reply Like
    • Travis Hamill also AirPlay is a good search term to look for.

      One extra bit of additional info. mDNS uses IP address 224.0.0.251. All addresses within 224.0.0.0/24 are local lan multicast addresses. Meaning they have a multicast TTL of 1. Then to confuse things (m)DNS also useses TTL values. These state the time an answer is valid to use/cache. Because it’s “complicated” and the fact that Apple uses mDNS for a lot of services the internet is full of info regarding this hence the best search terms are Apple services. 😂 

      Reply Like
  • Ingrid Niels de Klerk

     

    I have reset my brain numerous times, both connected via ethernet and wirelessly.  I have restarted my router and rebooted my remote.  It get stuck right at the "waaaaait for it" screen and then switches to the "failed to load screen".  

    Reply Like
    • Bryan West sounds like an issue in the remote ui. the App does connect i asume?
      What was the last change you made? do you remember?

      You could share your NEEO hostname to   Ingrid  and Jeff and they can let one of the dev's have a look.

      I can also have a look if you could share the contents of both:

      http://<BrainIp>:3000/projects/home/tr2/gui_xml
      http://<BrainIp>:3000/projects/home/tr2/guidata_xml

      also share some pictures of your remote's display in debug mode. so i can have a look at the error. To enter debug mode you press the menu button and then the channel down button about 6 times and the debug mode will be activated, so menu, channel down, menu, channel down, etc etc until you see it. do disable debug mode just do the same cheat combo ;-)

      Reply Like
    • Bryan West PS the info i am requesting will also help the devs. and I think you are having a different issue than the OP. one that is probably (if my assumption is correct) easy to fix.

      Reply Like 1
  • Ingrid  Jeff  Niels de Klerk  

     

    Ok - host name is neeo-d2271be6

    I might not be adept enough to find these, but when I copy and paste these into my browser these don't take me anywhere:

    http://<BrainIp>:3000/projects/home/tr2/gui_xml
    http://<BrainIp>:3000/projects/home/tr2/guidata_xml

     

    I'm probably not doing that right.  

    Reply Like
    • Bryan West could you press the try again button with the debug mode enabled? Then take pictures of the screen? The error won’t show up otherwise,

      The URL’s posted need to be changed with the IP address of your NEEO brain. Sorry I’m taking the difficult but more direct approach 😋

      You could try if these work.

      http://neeo-d2271be6.local:3000/projects/home/tr2/gui_xml

       

      http://neeo-d2271be6.local:3000/projects/home/tr2/guidata_xml

      Reply Like 1
    • Bryan West if you could share the up address (found in the about screen) I can make the correct url for you.

      where I live it’s almost midnight so I’m off to bed now but. I’ll have another look in the morning. Nn 

      Reply Like 1
  • Ingrid Jeff Niels de Klerk

     

    This is the screen shot of the remote.  I hope this helps.

    Reply Like
  • this is what that content is:

     

    This page contains the following errors:

    error on line 1 at column 27500: attributes construct error

    Below is a rendering of the page up to the first error.

     

    Then nothing else.  Thanks for the help Ingrid Niels de Klerk Jeff Michael Kohler

    Reply Like
    • Bryan West are you able to download the file? The message is your browser telling the same as the remote. It’s not the actual content.

       

      Maybe rightclick on the link and select download will work?

      Reply Like
    • Bryan West  

      Reply Like
  • Niels de Klerk  Michael Kohler Ingrid Jeff I don't seem to be able to download any associated file.  I right click and try and download the file or "save file as" and it takes me back to the same error message I copied earlier.  

    Reply Like
    • Bryan West you mean if you open the file after downloading I suppose? Can you mail the file to support@neeo.com or open it with notepad and post it here.

      sorry this is so complicated.

      An alternative is to factory reset your NEEO brain but this sets you back, the cause will remain a mystery and a fix to prevent this will die with the bug in sorrow. <\dramatic voice =off>

      Reply Like
  • Niels de Klerk Ingrid Jeff Michael Kohler

    I am not finding any associated file when I click this link:

    http://192.168.99.199:3000/projects/home/tr2/gui_xml

    There is no file when I click on it or right click to try and save it.  All it says when I click on it is: "error on line 1 at column 27500: attributes construct error"

    When I right click and try and save the file it says the same thing.  I am using a Mac.  Is there something I am missing here?  

    Reply Like
    • Bryan West Given your description, I think you are using Chrome. Open the link in Chrome and you will see the error box. Right click on that page and choose "Save As..." and save it as gui_xml.xml into your Download folder.

       

       

       

      Then send that file to me at michael.kohler@neeo.com

      Thanks!

      Reply Like
  • Michael Kohler   ok I sent it to you 

    Reply Like
    • Bryan West Thanks! It seems your "Samsung 75" TV has a unicode character after the "75". Possibly a ” (curly quote)? If you remove that character the interface should load again. This will be fixed in the next firmware release.

      Reply Like
  • Michael Kohler Niels de Klerk Jeff Ingrid

     

    Sorry to say, but I deleted that code from my Samsung 75 TV and the problem remains.   I completely renamed the TV.  I have reset the remote and reset the brain.  Unplugged and replugged the brain and router.  Used the brain wired to the router and tried to connect wirelessly.  One problem my brain has is that it seems to function really poorly on my wireless network.  

    Reply Like
    • Bryan West So the interface still can't be loaded? Would you mind sending me the file again? I double checked the version you sent me and didn't see anything else wrong apart from that name, but I guess I need to have a look at the newest version again.

      Reply Like
      • Bryan West
      • Bryan_West
      • 3 mths ago
      • Reported - view

      Michael  Niels de Klerk Jeff

      Reply Like
    • Bryan West Thanks for the updated XML. Looks like there is still a device/recipe around with that name. Can you go to the following link in Chrome and then from the Chrome menu choose File -> Save as and send me the resulting home.json file as well? Then I'll be able to tell you exactly which device/recipe is involved in this.

      http://192.168.99.199:3000/projects/home/

      Thanks!

      Reply Like
    • Michael Kohler could it be that shortcut, device names could still have the magic quote?

      Reply Like
    • Niels de Klerk yes, seems that something did not get renamed properly. Will know more once I get the project file :)

      Reply Like
    • Michael Kohler Looks like the shortcut's device names didn't get renamed. Will need to look into this.

       

      Bryan West you can remove the "Samsung 75" shortcuts in the Samsung Family Room and add them again, then they should have the correct name without the character. Then it should finally work :)

      Reply Like
    • Michael Kohler guessing correctly two times, I deserve a 🍺. Nom nom.

      Reply Like
  • Niels de Klerk Michael Kohler

     

    That finally worked!  I deleted all the shortcuts, and I will add them back one at a time to see which one screwed it up.  

    Reply Like
    • Bryan West the “ in the devicename caused this. The shortcuts you’ve added also included the name. You where having trouble because of two bugs. The “ character corrupted the file needed by the remote. A fix is already in place for the next firmware. The second bug is that the shortcuts didn’t got renamed when the device name was renamed.

      if you’ll add the shortcuts now you’ll be fine as the device name will be correct.

      Reply Like
  • Niels de Klerk Michael Kohler

     

    Ok.  I understand.  Thanks!

    Reply Like 1
  • Seems like this is a major problem with Neeo.  So why doesn't the Neeo team fix the problem?  Is this part of their customer prevention program??

    Reply Like
  • The issue continues with my Neeo and others.  

    Reply Like
    • Mike Buffa ah my mistake though you meant something else. That’s really annoying indeed.

      Reply Like
  • This is the current state of my Neeo after several tries to fix the problem.

    Reply Like
    • Mike Buffa what did you allready try to fix the issue?

      Did you allready try a repair of the Remote? Did your Neeo Brain a Reboot? Did you use dedicated IP-Adresses for your Neeo gear? Did you use DHCP handling? Is Your neeo Brain and your Remote in the same room? Are their in the same Network or did you use something like multiple Accesspoint, WiFi range extender, etc?

      I don't think your fault is related to the original in this Topic because the one in the topic was for unicode caracters that causing errors.

      Ingrid or  Jeff can you separate this post as new Topic?

      Reply Like
    • Markus Mahr I just noticed that there are two ip addresses in my modem for Neeo - one for Neeo and one for TR2-Neeo.  Why two ip addresses?

      Reply Like
    • Mike Buffa one for the remote, one for the Brain (wifi) if you have the cable still plugged in, there should be three.

       

      Can you answere the rest of the questions? Did you repair your remote?

      Reply Like
  • I have tried reboots. This is not an IP problem as my iPhone works just fine and the problem is intermittent.  The remote and Brain are within 8 feet of each other.  As there are many other folks having the same problem I would believe that there is a bug in the system that needs to be fixed. A product like this should work without having to hire an IT expert to tinker with settings that most users are not familiar with.  Neeo needs to step and fix this problem.

    Reply Like
    • Mike Buffa the questions asked by Markus Mahr are valid and help to find and hopefully resolve the issue you are facing. I hope you understand that the issue won’t get fixed if you don’t provide the requested information while responding with a attitude that wasn’t requested. Markus is taking his time to help you out, he is just like you and me a fellow NEEO user and doesn’t have to do that.

      I personally never have any connection issues with any of my four remotes. I’m not guaranteeing it’s not a bug but it’s highly unlikely. Most cases it’s related to one of Marcus his questions and that still includes a possible IP problem as a working iPhone doesn’t exclude that possibility.

      Reply Like
  • I have tried all possible solutions and continue to get sporatic connection issues.  This is not an IP issue.  It is either a bug or a defective remote as everything works fine with my iPhone connection.  

    Reply Like
    • Mike Buffa If you do a search you will find that there are several people experiencing the same problem, which leads me to believe that there is bug somewhere in the system.  As you know there can be numerous configurations in a given system and it appears that some may be buggy.

      In any case, a user should not have to understand subtle IT issues regarding DCHP or IP to make this system work. I have used Logitec remotes for years and never had to trouble shoot at the level you are suggesting.  

      Reply Like
  • I just noticed that there are two ip addresses for Neeo in my modem - one for Neeo and one for TR2-Neeo.  Why two ip addresses?

    Reply Like
  • Any idea of how to identify the third ip address?

    Reply Like
    • Mike Buffa If you plug in the cable, you sould see it within your router. Or you can plug it in and check the about section of the app menu. There you should find both adresses LAN and WiFi. The remote is only visible via your Router (currently) and also is only available if it is active (or if your router supports "previously connected devices").

      If you are going to go to the about section, would you also post your Neeo Hostname here? then somebody from the NEEO Team can check the Logfiles if they are able to find some reportings related to your issue, ALso Helpfull would be on which firmware you are currently at the remote and the Brain. i will mention Jeff and Ingrid here so they can peak a look and maybe provide even better details then i can.

      Reply Like
  • What is TR2 Neeo - I see this ip address connected to my router - I have it connected as a dedicated ip address?  I do find the WLAN IP address connected in my router - I have it connected as a dedicated ip address.  

    In addition, I see a LAN IP address in the About Section of the App that I do not find connected to my router - does this make sense?  After setting up dedicated ip addresses for TR2 Neeo and Neeo things seem to have stabilized for the moment.  We shall see how the day goes.

    Reply Like
  • Hi,  Mike Buffa. Thank you for reaching out to us and reporting this.

    I'm very sorry to hear about your connection issues. As Markus Mahr and  Niels de Klerk have already mentioned, we would need a few further information to be able to discover your connection issue.

    Which firmware are you running on your NEEO Brain and on your NEEO Remote (You can easily find this in your NEEO app or by tapping on your Remote on Settings > About)? 

    Which router are you using? (manufacturer and model number). Please make sure that your Wifi router firmware is also up to date. Is your NEEO Brain connected to a 2.4GHz network with channel width 20MHz? Please ensure that your smartphone is connected to the same network. Is "Prioritize NEEO Link" on the NEEO Remote enabled or disabled? (You can find this in your NEEO app > Settings > Neeo Remote)


    Please check if DHCP is enabled on your network, and you are using WPA/WPA2 encryption. Did you set your wireless band automatically or on 802.11.n+g+b?

    You could also try to set a static IP address and try network channel 1, 6 or 11. 

    Reply Like
  • App Firmware 0.51.13-4f47f9b.  Remote firmware is 0.51.13-4f47f9b.  Using Apple router. Router firmware is up to date. Connected to 5 G. network.  Everything is on the same network.  Prioritize Link is off.  DHCP is enabled and I am using WPA/WPA2 encryption.  Wireless band is automatic. I have set static ip for Neeo and TR2 Neeo (what is TR2 Neeo) in the modem.

    Now, time for my question.  Are you kidding me.  Are you telling me that I need to be an IT expert to use your product.  I would guess that the majority of users that use a remote would have no idea of what you are talking about nor would they spend the time to do the level of troubleshooting that you require - a user just wants a product that works.

    Reply Like
    • Mike Buffa neeo is not able to connect to a 5 GHz network. You need to make sure, that your router also spread a 2.4 GHz network to make neeo remote work. This is also visible in the tech specification.

       

      And no, you don't need to be an expert to setup and use a product, but when it comes to an issue, it is allways helpful to have as much information as possible to track and hunt it down. That's why you're ask these questions. 

       

      Having issues I never a good user experience. But this happens all the time with each and every device today. If this would not happen no need to update devices (e.g. Laptops, mobile phones, router,...)

      Reply Like
    • Mike Buffa I had the same error message and similar symptoms. In my case, as Ingrid suggested, changing the Wifi channel in the router setup from 12 to 11 solved the problem.

      Reply Like
    • Hi, Mike Buffa. I'd like to follow up if this was solved for you after you connected to 2.4Ghz, as Markus Mahr mentioned? (=> NEEO only communicates via the 2.4Ghz frequency)

      Reply Like
  • Things stabilized once I setup static IP addresses.  You guys have a lot of work to do to make this a user friendly product.

    Reply Like
reply to topic
Like Follow