Who has "Cannot communicate with brain" issues?

Cannot communicate with brain.

NEEO Remote, always!

 

Hi all

It's not a good sign, when the users of a product have to debug issues, but I made some progress on my issues and that's why I wanted to try to further isolate it. Maybe it helps others as well.

I always had the issue, that the remote and app showed, that it cannot communicate with the brain. Sometimes it worked again after a minute but mostly, I had to reboot the brain. It happened multiple times every hour and it made the remote pretty useless. 

While I really wanted to fix this issue, I even replaced my WiFi setup completely. I'm running the new setup for only one day now, but it looks promising so far.

I used Ubiquitiy Access Points (2x Ubiquiti UniFi AC-PRO) before when I had all these issues. Does someone - by any chance - use these AP's as well and has the same issues?

Or all the others which have the same issues, can we maybe collect some details about it? Maybe we can - at some point - isolate the issue to be sure what's the reason for it.

Reply
6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I had connection issues when I didnt assign a fixed IP to Brain and Remote. This was independent of which hardware I used ( AVM FritzBox and Telekom W724V)

    Reply Like
  • I have only the problem with the APP and I am also using Ubiquity AP's . the problem I found out is that in a multi-AP enviroment if the mobile phone and the brain are not connected to the same AP (Ubiquity supports "roaming") this problem arises

    Andy Ingrid which mechanism is used to located the brain? is the app searching on iso layer 2 or 3/4? or in other words are you using some kind of "broadcasting" messages on L2 which are blocked in certain network environment setup's?

    Reply Like
    • Simon Saado 

      In the search box top type : Router setup. There are all topics about connection issues!

      But what I should emphasize is (1) Set the same SSID's and password in all your access points (AP's) (2) Set all three MAC addresses of the Brain and Remote (2 for the Brain and 1 for the Remote) in the MAC filter. And one more thing make sure that the 2.4 GHz and 5 GHz radios are enabled on your phone and the router! The Brain and Remote use 2.4 GHz

      Then reboot everything!

      Tip : Keep the Brain connected to the router with an Ethernet cable.

      Eman.

      Reply Like
    • Simon Saado I use a multi AP WiFi network with ubiquity as well. Discovery of the app is based on MDNS.

      be sure not to block multicast and there’s no router in between the hub and your app. (MDNSuses a TTL of 1) 

      what I think is mist likely happening is your mobile device might use the option WiFi assist. Please check if you’re having issues with WiFi assist disabled.

      Access Wi-Fi Assist setting

      1. Tap the Settings app to launch it.
      2. Tap Cellular. Or Mobile Data depending on iOS version.
      3. Scroll all the way to the bottom, past the list of apps that use cellular data.
      4. You should find a setting for Wi-Fi Assist. You can switch it on or off.
      Reply Like
  • Hi Emanuel, thanks for the suggestions, but I think this is not the problem, as the brain and remote have no "connection problem". they are always fully functional and reachable on ip level. there is also no mac filter in place in my environment, also my setup uses 2.4ghz AP only

    also I don't see the need of having ethernet cable because I use a DHCP/MAC binding so the brain is getting always the same ip

    it must be a iOS app problem in conjunction with the automatic brain search. still interested in the search/connection approach to dig depper in the analysis

    Cheers,
    Simon

    Reply Like
    • Simon Saado Hi,

      I use the iPAD Pro myself and have no problem to connect : Wi-Fi (802.11a/b/g/n/ac); dual band (2.4GHz and 5GHz); HT80 with MIMO .

      So I believe it's got to be on your port settings. Try and turn on Multicast for your WiFi devices from the ports on your switch. I have not setup my Ubiquity AP's and switch to pin this down.

       

      Eman.

      Reply Like
Like Follow