Can't connect to Brain since network AP change


I'm having a very strange problem with my NEEO Brain, and it is the result of me upgrading my network.

The problem is that my NEEO app finds the Brain, but when I try to connect to it, I get a 'Connection Failed. It looks like the "Welcome to NEEO" isn't responding.' error.

I tried rebooting the Brain, uninstalling and re-installing the app, connecting via Ethernet to my new switch. Nothing worked. Constantly with that Connection Failed error, even though it finds the brain.

Then I tried turning my old router and wifi on... and it worked fine. The app connected to the brain and brought up my profile.

So I figured it was an issue with config on my new setup and the brain not letting go of some sort of fixed IP it was getting. So I configured my new network with exactly the same SSID, WPA key and even statically assigned the same exact IP the brain was getting from my old router. But this still didn't fix the issue. It was connecting to the Wifi on my new AP and getting the same IP... but the same connection error.

I then connected it all back up to my old router, and did a brain reset via the app. Thinking this would be the trick as it would forget my old router and settings. So I did that, connected it to the LAN of my new switch, confirmed that the brain was no longer connecting via wifi... uninstall the app, reinstall it (Android btw), go through the motions of setting it up... it searches for the brain, finds it... same connection error!

I'm now at a loss. For what it's worth, I've run a packet capture from my switch which is monitoring just the NEEO brain's IP. You can see it constantly hitting ARP, you can even see the prompts for the welcome to NEEO page as I go through initial setup on the app before it fails. But it's not telling me any more about why the connection isn't establishing between the app and brain.

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • For the sake of anyone having a similar issue, I just fixed it. I added both the brain and my android device to a network whitelist. Looks like my device was restricting some form of communication between the devices.

Like Follow