Remote Unable To Connect to Brain and Wifi

Hi,

Though I have sent my woes to support, don't know if they are still there to support Neeo products as they were. So, as the heading says, I have tried restarting the brain, pressing the start and mute buttons on the remote to install firmware  as well as press start and 'back'  buttons to re-pair. Even removed the LAN entry and got a new IP for the brain but the remote still would not reconnect. Enclosing some pictures. Though it works just fine with the app on my iPhone. However, wondering if someone is out there to help. Will be truly appreciated.

Reply
4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • In my experience WiFi is poor on both brain and remote (which is why I keep the brain on LAN permanently). But as you indicate the phone controls the brain fine you know the problem is with the remote. I would try to get the remote closer to your WiFi router, experiment with the NEEO link priority setting or even choose a different WiFi channel on your router

    Like
    • Geert Van Der Linden Thank you for responding. Tried with prioritisation setting enabled but that did not work either. I have tried this sitting next to the router too. Any clue how does one factory reset the brain? Then maybe I can try pairing again.

      Like
    • Anaam Mishra press down on the brain (this is not a factory reset but will re-pair the connection) but I still think the issue is with the remote. Press the power button on the remote until it powers down or  offers you the option to restart

      Like
    • Geert Van Der Linden  thank you for the help. I got a response from Control4 support. This is what worked:

      If the NEEO Remote is still unresponsive try the following:

      1. Hold the power button on the NEEO Remote for 15 seconds

      2. Wait a few seconds

      3. Press the power & mute button simultaneously for a few seconds

      4. You should see the option for recovery, follow the on-screen steps

      Like
Like Follow