Easiest install on earth, my arse.

Hi there, have been attempting to create a new account via the app on Iphone X for the last 2 hours and having no luck every time i try i get the message "could not signup"

I've seen the previous issues in discussions, with seemingly no further information about how to fix the problem except that old "reboot the router" chestnut, which also has had no effect.

 

Would love some help or this thing is going back to the supplier on monday morning.

Reply
4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Rob Lynes Did you already try to force end the app, reboot the neeo brain and recheck if account can be created? Also make sure that for the first steps the Brain needs to be connected via LAN to your network. Only wifi is not yet possible.

    To make sure you will receive help, i will pull in Jeff he is also available for phonecalls in california office times.

    Also will pull in Ingrid as swiss technician.

    Reply Like 1
  • Just spoken to Jose in the CA office, decidedly unimpressed so far, keeps telling me its an NTP problem.
     

    Have tried all the recommendations from above, Brain has been connected to LAN, not intending on using wifi TBH, have rebooted the brain several times, tried multiple email addresses and nothing has worked so far. 

    Have tried via my normal router rebooted it etc, and nothing, Plugged it into a Netgear Nighthawk M1 and have been able to get an account setup.

    Reply Like
      • Jeff
      • Head of Customer Experience
      • Jeff
      • 5 mths ago
      • Reported - view

      Rob Lynes Hi Rob, thank you for reaching out to us here on Planet NEEO and sorry to see that you're experiencing this. What you are experiencing is related to your routers NTP. When you fail to login, you should see a link at the bottom of the app screen that says "Diagnostics". Can you screenshot this and DM me?

      Reply Like
  •  as requested.

    Date seems to be 2018 not todays date.

    Reply Like
Like Follow