Recipe step does not execute when run

when i run a recipe for my a/v system, one step does not execute properly. i see on the Neeo remote UI that Neeo is running the step for my "not-so-smart" device but it does not execute. however, the step works 100% of the time when i test the recipe step in test/edit mode ("Test this step") and it also runs when i click the manual step after i run the recipe. the component is a pretty old hdmi switch, Atlona-hd4-v42, but Neeo seems to be sending the right command but just not part of the original recipe execution. looking for a fix/recommendation. 

8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I figure this is going to be requested .... so here is the recipe screenshot.

  • +1.   I have added/removed so many recipes on Neeo I'm ready to give up.   All I have is a Sony TV, Fios box and a Boston Acoustics sound bar of sorts.  Can't get it to work at all...nada, nothing. 

    Things go on, things go off, no sound, no channel changing, it's like stuck.

  • Hi,   David Banks. I'm very sorry for my late response. To get a better understanding of your set up could you help me with these questions:

    Which devices are connected to your HDMI switch? Which step in your recipe doesn't perform well? Could you describe what your recipe is supposed to do?

    Could you please check the name of your HDMI switch, you have added. Do you use a "device smartener" for your "not-so-smart" device? 

    There is also an interesting thread over here which could be helpful.

  • HDMI Switch (Atlona-hd4-v42) input: Appletv, cable box output: samsung tv

    Non-performing recipe steps: 3 (turn on switch), 7 (switch to input 2) 

    The recipe is designed to turn on the tv, sonos playbar, apple tv, and the hdmi switch. Once the hdmi switch is on it should switch the input 2. 

    I tried to run the "device smartener" but it didnt work. I'm not sure my device is compatible for this type of configuration. 

    •   David Banks Hi, thanks for all information.
      Could you please check if you can turn on your HDMI switch with your NEEO separately? If not, this probably comes from the brain position. Could you please try placing your brain closer to your device, to send more IR signals?  You can also try repositioning the additional IR emitter. 

    • Ingrid Ingrid yes i can turn the HDMI and switch the input from Neeo but not when i run the full recipe. there is no issue with the neeo brain placement. as mentioned above, the step works 100% of the time when i test the recipe step in test/edit mode ("Test this step") and it also runs when i click the manual step after i run the recipe.

    • David Banks could you try the following? (All using the app) Turn off all activities, then go to settings -> devices , select the ... on Apple TV, then the reset wireing option.

      go to the home menu. You’ll notice that an icon is displayed on the AppleTV recipe, tap it, now follow the wizard again.

      the recipe should now be re added and I hope this will help.

      If it doesn’t help, could you try the following?

      edit the recipe, change the delay and add 2 seconds and turn off smart delay. I’m not sure your issues is caused by the delay but it doesn’t hurt to try. If it doesn’t help than could you add a half a second delay before and after the switch commands? Both with the smart delay switch turned off. Because sending the commands separate work for you I’m thinking that the switch might only listen when no other commands are send just before or after, the half a second before and after might help. If this did the trick than bring down the 7sec delay back to 5 and enable smart delay back as it was set in your screenshot.

      hopefully this helps.

  • It appears that adding the delay worked. I added 1sec delay before the HDMI switch command but need to keep the smart delay disabled. Even though it takes 6 secs to run the recipe (which is much slower than the old Control4 I replaced), I'll take it for now and move on. At least things work the first time I execute the recipe. 

Like Follow