IOS app version 0.50 showing blank icon canvas

On my two iOS devices the NEEO app automatically updated to version 50.0 (previous version I believe was 48.2). The App Store description claims better performance under iOS 11 and faster (re)connecting to the brain. This definitely appears to be the case which makes using the app much nicer (though I still much prefer the remote).

But on my iPad Pro 9.7 the NEEO app no longer has an icon (meaning iOS now shows the default blank icon canvas). My iPhone has the same version of iOS but still shows the NEEO icon. I’ve obviously tried restarting the iPad. Anybody else experiencing this?

Reply
25replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Jeff@NEEO
    • Head of Customer Experience
    • Jeff
    • 10 mths ago
    • Reported - view

    Hi  Geert Van Der Linden !

    We don't have an official app for the iPad at the moment. The NEEO app is currently only developed for the iPhone. Once we have an official app for the iPad we will announce it :).

    Thanks!

    Reply Like
  • It should not behave different on a iPad than on a iPhone. As on an iPad it’s just presenting the user interface with a iPhone scale.

    have you tried to remove the app and reinstall it?

    Reply Like
  • I have the same issue. Rmove and reinstall not solve the problem. Reset home-screen can‘t help too. Not a big problem but not realy nice......

    Reply Like
  • Jeff maybe it’s just terminology but you do have an official iPad app, I know because I have it installed for many months now. You have no app that is optimised  for iPad, it is only optimised for the phone but it works fine and I prefer to use the iPad when making changes to my configuration.

    Anyway, it still works fine and it is not a big issue but it also shouldn’t be a big issue to fix either and it just looks a bit sloppy so thought I’d mention it.

    Look at it this way, if a lot of apps showed blank icons we’d have a real issue because nobody would find his apps anymore, when only the NEEO app shows a blank icon I find it just as easy but it doesn’t give that premium feeling, does it?

    Reply Like
    • Geert Van Der Linden agree with you!

      But anyways, the App should be easily adapteble for iPad, but not done yet. i mainly do changes the unofficial way...

      Hope that sone day, the App is available as also a web interface for manage and usage.

      Reply Like
    • Markus Mahr I am intrigued, which unofficial way is there to do updates?

      Reply Like
    • Geert Van Der Linden Brain is accessible by every browser, but this is not officially as there are limits in support currently.

      Reply Like
    • Markus Mahr clear. I accessed the brain through my browser before, to see if I could change icons that way ...

      I remember thinking I’d need a better look at the structure of the data before attempting that. Good to know it can be done ;)

      Reply Like
    • Markus Mahr Browser..... i didn't know that yet. Great!... http://{IP_Brain}:3200/eui

      Reply Like
    • Peter Muerner be warned that it’s officially unsupported. Things like pressing buttons won’t work. For making some configuration changes it’s just perfect.

      Reply Like
    • Niels de Klerk Thx for this Info

      Reply Like
    • Markus Mahr I imagine it is even less supported but have you ever tried accessing http://IP_BRAIN:3000/projects/home and making changes there?

      Reply Like
    • Geert Van Der Linden you can read my API guide to get you started.

      Reply Like
    • Niels de Klerk was already doing that ;) thanks!

      Reply Like
    • Geert Van Der Linden I didn’t document the potentially dangerous API calls. I f###ed up my system a couple of times but I was always able to repair it. Make sure that if you add something that you also know how to remove it in case it goes wrong.

      Reply Like
    • Niels de Klerk thanks for the advice. At least for now wasn’t planning anything too dangerous or automated. Make small manual change, test, remove if necessary :)

      Reply Like
    • Niels de Klerk didn't do anything dangerous yet but struggling to get fields from a collection. I can get down to a specific device but if I want to get its name for example I cannot seem to make the ?h=*fields: part of the call work. Have you experimented with this before?

      Reply Like
    • Geert Van Der Linden I’m sorry but I have no idea what that is you are trying. 

      What I did was using wireshark and capture the API calls that the EUI made. I’m using a lot of them in my homey app. For instance: starting/stopping recipes, editing favorites, upgrading the brain, pressing buttons and checking recipes status. I made these available to the homey UI.

       

      is there anything in particular you are looking for?

      Reply Like
    • Niels de Klerk I am investigating if I can use REST to customise my configuration (assign a different icon, rename a recipe, rename a shortcut, etc.) It seems easy enough when looking at http://IP_BRAIN:3000/projects/home where just a couple words need changing and in a past life I did many of such "dangerous" updates in an SQL world. But right now I cannot even get the GET statement fine-tuned enough.  

      I was also using Wireshark to see if I could get any wiser but I am attempting stuff that is not yet supported by NEEO, in other words there are no API calls to capture. 

      Reply Like
    • Niels de Klerk figured out the syntax of the GET statement:

      http://IP_BRAIN/v1/projects/home/rooms/ID_ROOM/devices/ID_DEVICE?fields=details/icon

      This returns only the icon of a specific device ... now I wonder if I can update that value ...

      Reply Like
  • Jeff after a very interesting detour to Niels de Klerk API guide, a quick reminder on the original topic :)

    Reply Like 1
  • Based on this thread there are only two iPad Pro users with the NEEO app installed.  It still has no icon ...

    Reply Like
      • Jeff@NEEO
      • Head of Customer Experience
      • Jeff
      • 5 mths ago
      • Reported - view

      Geert Van Der Linden Hello!

      Please note that we (NEEO) do not have an official iPad app. When we release one, we will announce it here on Planet NEEO.

      Thanks!

      Reply Like
    • Jeff we’ve been here five months ago ... you may want to scroll up to the beginning of this thread

      Reply Like
  • 8 months later, still have no icon on the iPad, maybe Jeff wants to tell me one more time NEEO doesn’t have an official iPad app? Oh well, guess things could be worse, imagine NEEO would cease to exist and we could stop waiting for the product we were promised?

    Reply Like
Like Follow