Brain never detected after leaving / returning to home

EVERY time I leave the house and return the phone app is not able to find the Brain. Repeated attempts result in the same outcome: "Sorry, no NEEO Brain found.

However, the remote continues to work.

I'd sure like this to work. Since it is new, I am constantly wanting to add new favorite channels and new recipes. Except I can't since the Brain can't be found.

I tried repeating the entire process on the day I set it up. It would reconnect, but that is not a viable system if I have to repeat the entire set up every time.

40replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Matt Lippmann Did you set Up Your NEEO BRain and disconnect it from the Network? Basically means, did you run on WiFi or on lan wired connection? What Firmware are your NEEO Brain and Remot on? Did you check, if your router still displays the NEEO (needs 2 IPs if connected with LAN and WiFi) and your remote(third IP when awake)?

    Did you use DHCP for the Brain your telephone and the Remote? Is your WiFi set Up to let devices talk to each other and also to devices on your LAN or did you have VLANs setup?

    I'm sure Patrick will follow up this Topic and reply with some additional steps to check and help, but these are fore sure asked questions that help to provide an idea what can be happening.

  • NEEO was set exactly as instructed by the app. First connected via LAN. Updated firmware, connected to WiFi then disconnected LAN. Should only be connected via WiFi as instructions say to do  

    Router allows devices to talk to one another. Several other devices on network do so. 

    Router and devices use whatever is default to connect.

    router shows BRain when it connects to App only. Not when it isn’t being connected. 

  • Matt Lippmann You are totally right, we need to solve that. Having to go through the setup every time is no solution.

    I know you are running the latest firmware from other threads.

    Could you describe your WiFi setup a bit more? Are you using a single WiFi Router or is that a mesh network with multiple APs? What kind of encryption are you using? Do you have a 2.4 and a 5Ghz network setup? That would give us a chance to reproduce this.

    You say your NEEO Remote is still working in that condition. What that means is that there actually seems to be a network issue, not a NEEO Brain that crashes completely. Do you have NEEO Link enabled in the NEEO App settings?

    When you just unplug your NEEO Brain and plug it in again, does it reconnect?

    I sent you a personal message too for some additional tests.

    • Hi Patrick , I use a single router, the Asus RT-AC88U.

      I use WPA2

      The router runs both 2.4 and 5 GHz simultaneously, it auto assign the band based on the device. The NEEO shows up on 2.4 GHz when it is working

      NEEO Link is enabled

      • Ian White
      • Ian_White
      • 2 yrs ago
      • Reported - view

      Matt This sounds exactly like the issue I was having too, except I'm on an Asus RT-AC5300 router. (The other symptom I noticed was that my Google Home frequently didn't show up in the Spotify app, which is really what caused me to search for a fix.)

      I've been able to resolve it by modifying a few settings in the router configuration. Specifically these settings related to multicast:

      LAN -> IPTV: Enable multicast routing (IGMP Proxy) : Enabled
      LAN -> IPTV: Enable efficient multicast forwarding (IGMP Snooping): Enabled
      Wireless -> Professional -> Band 2.4GHz -> Enable IGMP Snooping: Enabled
      Wireless -> Professional -> Band 5GHz -> Enable IGMP Snooping: Enabled

      Note that I did have to enable the LAN settings too, even though my Neeo is usually on WiFi. I enabled the 5GHz snooping because my iPhone is often on that band. I also did a reboot of the router after all these changes.

      Some other people have suggested that they needed to modify the setting "Wireless -> Professional -> Band 2.4GHz -> Multicast Rate(Mbps)", but I don't believe that one is actually related.

      • Patrick@NEEO
      • Community Manager
      • Patrick
      • 2 yrs ago
      • Reported - view

      Matt Lippmann It be really nice if you could give the settings which  Ian White posted a try and let us know if that makes a difference. 

      Ian White Thanks a lot for sharing this 👍

    • Patrick sorry for delay responding. I recently (last week) had shoulder surgery to repair a torn rotator cuff, shredded bicep tendon and labrum tear so have been somewhat limited.  having to do everything one handed with non dominant side makes everything challenging.

      My current settings:

      LAN -> IPTV: Enable multicast routing (IGMP Proxy) : disabled
      LAN -> IPTV: Enable efficient multicast forwarding (IGMP Snooping): disabled
      Wireless -> Professional -> Band 2.4GHz -> Enable IGMP Snooping: disabled
      Wireless -> Professional -> Band 5GHz -> Enable IGMP Snooping: disabled

      I need to be 100% certain that making changes to my router will no impact other aspects of my network. my wife and I rely on it for work  

      I made the changes and initial results are I was able to find the two brains on my network with one try. I will be leaving the house later today so can test that scenario then.

    • Patrick this problem with poor connectivity between the Brain, remote and app is a real problem that is rendering the NEEO System more hassle than its worth. Despite the router changes, now the Brain AND Remote lose connection, even when I haven't left the house! With both remote and app not functioning the NEEO is useless. 

      this happens EVERY DAY!

      Please provide a stable solution

  • making the wireless changes caused the remote to loose connection to the brain. reconnecting attempts result in the "oh no! Something went wrong! Failed to load." message.

    Took at least 20 times to reconnect/pair the remote!!! I've rebooted. I repaired,  "tried again", and powered off. Same irritating message.

    "Something went wrong" message is not helpful. is it the network? Pairing? The remote? What?

    Finally, randomly, remote connected. 

  • solution has not worked.  left and returned, trying to connect via app. same issue, can't locate Brain. as before, will likely take upwards of ten attempts, killing app on phone and rebooting phone in order to connect. 

    can this be because the brain can only handle one wifi connection? phone app vs remote?

    this wouldn't matter if the remote could be used to make changes (recipes, shortcuts). 

    • Matt Lippmann Definitly no, the Brain is capable of multi connections. It haldles up to 9 Remotes and the Phoen App if i understand correctly.

      Did you allready managed to Update to the new Firmware? If not, it is worth a try!

    • Markus Mahr yes I updated the firmware. that resulted in the remote losing connection to the brain. So now, Bothe app and remote frequently (daily) lose connection with the brain, sometimes multiple times a day. And it has started happening without leaving the house. For instance, I spent over 30 minutes this morning trying to get either the app or remote to connect! I had try multiple attempts at repairing the remote, multiple reboots and power cycles. it is very frustrating and not viable was a product. 

  • In addition to the brain continuing to disappear from the network, now the remote has started losing connection as well. Trying reconnect results in a failure to load the interface. I’ve tried repairing, restarting and rebooting. None of which works.

    Add that to being unable to connect with and app and the entire NEEO system is down.

  • Matt Lippmann I hope you are all fine after your surgery.

    We are analyzing this, but so far our developers have not found anything that would give a hint to the reason for which your NEEO Brain is losing its connection. Do you see any chance to plug the NEEO Brain into ethernet for testing if this makes a difference? This way we could figure out if it really is the WiFi connection or if might be caused by something else like a crashed service.

    It would be nice if you could plug your NEEO Brain into ethernet again, then go into the settings and configure WiFi again, basically saying change the network, but then choose yours again. After that, please repair your NEEO remote by first turning it off and then holding the hard buttons "power" and "back" at the same time, then follow the instructions on the screen to repair your NEEO Remote.

    Once that is up and running again, please updated to the latest release from today. When that is done, you can try switching back to WiFi on the NEEO Brain by just unplugging ethernet.

    I can not imagine how you leaving the house would influence the WiFi connection on the NEEO Brain in any way, for that reason and because you actually said it is now happening when you are home too, I do not think this is related.

    • Patrick I can try this, however I am recovering from extensive shoulder surgery and am without the use of my dominant arm. Connecting to a LAN cable requires moving equipment and furniture around;  difficult without two arms.

      how does one reconnect to WiFi without wiping out all other settings in the process? 

      Running a LAN cable to the Brain location as a permanent set up is not an option for the Brain in the bedroom. There is no network drop there.

      Also, the Brain in Great Room can't be set up this way either due to need to place the Brain is a place that it can control the devices. This location is not close enough to the network drops.

      Further, the Brains will show up on the network. Even when a Brain is visible on the network it still has trouble staying connected or reconnecting to the app/remote.

      The problem in my opinion is the failure of the Brain to be seen over WiFi by app/remote, not the Brain being connected to WiFi.

    • Matt Lippmann I don't know how technically fit you are, but can you try to set a dedicated ip Adress for the Brain in your router using the MAC Adress of each of the brains and then maybe do the same for the remotes. 

      Does your router kill devices in stand-by and kick them out of your network? Also maybe you can only provide one Brain with power and see, if the app remote got the same trouble or not. 

    • Markus Mahr I am comfortable making such changes so I followed your suggestion.

      Doing this caused a third NEEO to appear in the router device list named "TR2-NEEO-884aea55ed83". The router thinks it is a Canon Photo Printer, a device we don't own.  The IP and MAC address does not match anything. This is the first time the third NEEO device has appeared. It is "stable" in that it doesn't remain in the device list.

      How does one dedicate the IP address for the remotes? They don't been showing up in the router's device list.

    • Matt Lippmann The Remote must be active and you can check witch IP it own in the about menu. Then you can add it. Also a Network Scanner is sometimes helpfull to detemine a MAC, sadly the MAC Adresses of the Brain and the Remote is not visible in the Menu in the current Version, hope this will come.

      If you set up your Brain via RJ-45 and Wifi you should have three IP-Adresses used, means the RJ-45 uses one, the WiFi from the Brain uses one and the remote uses one.

      Also it can be, that your Network (DHCP) Doesn't have the ability to provide further 6 adresses (when using both Brains)? Therefor i suggested to use Dedicated IP's depending on the MAC, they normaly are out of the DHCP Range.

      The Remote shows up as mysimplelink normaly, TR2 is the "internal" name for the Remote Website that the Remote shows you on the Display. So this device can be your Remote. I'm currently not able to tell how the remote appear on the Network, i allready set then dedicated names and IP-Adresses. This makes it much faster during usage!

      The Name or Manufacturer is assigned from your Router using the MAC adress to filter every Manufacturer, NEEO isn't in the actuall Database used for that with their MAC Adresses, and also your Router Manufacturer must use the newest Version to determine the Type of Equipment.

    • Markus Mahr OK, the device is the remote. However, it appears very rarely in the router's connected device list. Even while using the remote, which is likely why I've never seen it before. I have tried actively using the remote while simultaneously viewing/refreshing the router's connected device list to try to see the remote. The remote doesn't show up. The remote does work while doing this (i.e. controls DirecTV).

      The remote's "about" menu does not list an IP address. The Brain it is connected to is listed in the remote's "about" menu. There are two Brain IP spots, one each for WiFi and LAN. No line for the remote.

    • Matt Lippmann OK, I managed to "catch" the remote in the router's connected device list and assigned a permanent IP address before it disappeared. 

    • Matt Lippmann Then you need to resetup the WiFi in the Brain and reconnect the Remote to the Brain. It seems, the Remote is not able to connect to WiFi. But is connected via NEEO Link. I also had such behavior a few times. But we are now on the right way. Do you know how to setup the WiFi again?

      Set Up WiFi:

      Open Menu in the App, select Neeo Brain and select Wifi Setup. Redo the steps required. Best is when an LAN Cable is also connected during this!

      To repair your remote go as following:

      Power Off the Remote and hold Back and Power ON at the same time until the display shows instuctions, follow them to repair and reload the WiFi credentials to the remote.

      Check if the Remote displays the Wifi Bars in the upper right corner beside the vertical Dots (indicating NEEO Link) and recheck if an IP for the remote is visible.

      If so, the error should be solved. As descriped previously (somewhere on Planet NEEO) the NEEO Link is used to send Commands to the Brain, the WiFi is used for larger amount of data (like Pictures, Software Updates and as Fallback) if NEEO Link is available, the Commands work fine, but you run into trouble when loading Images and the Actual recipe stage

    • Markus Mahr Took several attempts to repeat WiFi setup as the Brain disconnected from the app (despite being listed in the router's connected device list).

      Now, trying the remote repair. Turned off remote. pressing back and power does not result in instructions to repair. It results in the NEEO new remote screen with "Hi, nice to meet you." and Get started displayed. Selecting Get Started only instructs to repair with Brain. This process ends up with an error loading the interface. Required repeated attempts to get remote paired again. 

      Three dots are displayed.

      Now they appear in router's device list. Dots still displayed on remote.

      Will report back if stable.

    • Matt Lippmann actually during the repair, the remote also loads the credentials from the NEEO brain. Does your NEEO now display both, the dots and the WiFi bars? Did it show an ip in the about page?

    • Markus Mahr Remote displays both WiFi and three dot symbols. 

      No remote IP line in "About" menu/page. Brain IP only

    • Matt Lippmann I also don't see an entry in the about page. Seems that this is gone from the menu. Patrick can you check that?

      • Patrick@NEEO
      • Community Manager
      • Patrick
      • 2 yrs ago
      • Reported - view

      Markus Mahr If I remember correctly, we have never shown the IP of the NEEO Remote in that screen, only the two (Ethernet & WiFi) IPs from the NEEO Brain.

    • Patrick Thanks for checking. I'm really not sure about that.

      Please consider adding the MACs of the Brain and the IP and MAC of the remote. This would be helpfull for everybody who whants to add DHCP IP Adresses specified by the MAC Adress.

      I'm able to find all these Infos with the Debug ;-p

  • Problem has returned overnight. Brain no longer detected by app. Remote displays WiFi but not 3 dots. Brain appears in router connected device list. Remote does not. Remote "About" lists IPs for Brain only. 

    • Matt Lippmann Ok, the 3 dots need a few minutes Up and running, are the about page display two IPs or only one?

      I found out, that in general the IP of the remote doesn't show up in the about page. But this seems a very strange issue. Due to the fact, that it is Saturday i don't know any further steps to test. Patrick will for sure come back on Monday and writes something.

    • Markus Mahr three dots never showed up. even an hour after first use.

      Power cycled remote, now remote can't find Brain, will not connect to Brain!

      Brain still in router device list, remote is not.

      after ~10 attempts and rebooting phone, app finally found the Brain 

      At this point I think I'd like replacement Brain/Remote. These are clearly defective in some way. Having problems every day, multiple times a day is not a viable system. 

    • Matt Lippmann This will for sure be the end part. If you whant the 3 dots again, you need to Repair the remote i guess. But this should definitly not be the normal way or normal function.

    • Markus Mahr Exactly, repairing constantly is not acceptable. Further, repairing often results in errors failing to load the interface.

      As stated earlier, I'd like a replacement Brains/remotes, I have two.

      The other option will be to request full refunds for both Brain/Remotes and just go back to Logitech, at least those were reliable day in day out.

  • this morning the remote started of working, then suddenly, right in the middle of performing operations, it shut down and rebooted. Naturally, the Brain could could not be found by the remote. Repairing did not work.

    similarly, the app can't find the Brain. Oddly, the Brain not in use in the bedroom shows up in the app.

    So, now I'm into the cycle of repeated attempts to get any of it to work.

    This is ridiculous, I am now formally requesting replacement units ASAP. I am through wasting hours every day trying together this to work.

    Please advise ASAP when you will send replacement equipment.

      • Patrick@NEEO
      • Community Manager
      • Patrick
      • 2 yrs ago
      • Reported - view

      Matt Lippmann Sorry for all the issues you are still seeing. You are right, let's replace your NEEO Combo, I am honestly running out of ideas as well. I will have our support team get in touch with you.

      The only idea I also, which also popped up already in this thread, is that you are actually running out of IP addresses. This could also be the link to you leaving the home or not. Is the IP range in your DHCP settings big enough for the number of devices you have in your network?

    • Patrick Thank you Patrick. I have two NEEO Combos that both have issues, though the one I use most often has the most problems.

      IP range under LAN DHCP settings of my router:  XXX.XXX.1.2 to 1.254

      I have ~20-25 devices that connect to the network via a mix of cable and WiFi at any given time depending on usage.

      Would the IP availability affect the NEEO Link? Yesterday, NEEO Link was eventually working once I got the remote repaired to the Brain. However, after ~4 hours of use channel surfing while watching Football, the NEEO Link dropped and never came back as evidenced by the three dots on remote display. WiFi stayed connected. This morning the remote is only connected to WiFi. Does that have anything to do with IP addresses?

      Also, this morning there is no connectivity to the app. Despite after a full day of being able to see the Brain on the app, The only change was nighttime. Both NEEO Brains appear in the router's device list this morning.

      FWIW I really like the NEEO system when it is functioning and very much want to see it be successful. There are a few things I'd change, such as the layout of commands across the DirecTV screens to better align with actual use. For example, put the guide, menu and my recordings commands on the same screen. Similarly, put previous channel, skip fwd/back, info and Exit on the same screen (previous channel and Exit  have to be added as shortcuts).

      I also don't quite understand the function of the physical Back button. it doesn't really function as I'd expect, such as a previous channel button. it seems to go back to the last guide/menu screen.

      Look forward to hearing from the support team.

      • Patrick@NEEO
      • Community Manager
      • Patrick
      • 2 yrs ago
      • Reported - view

      Matt Lippmann No, the IP/Ethernet connections should not affect NEEO Link, that is a completely different technology. Dependant on your environment NEEO Link can go down, we are working on making this much more stable. This should not affect the functionality of your NEEO, we do send all commands over Wifi when NEEO Link is not available.

      Oh, somehow I haven't realized yet you have two units. I would still go ahead and exchange one, however, chances that both do have a defect which would result in connectivity issues are tiny. I need to check with the team, I want to be honest, I am running out of ideas here a bit.

      I have forwarded your wishes to our UI designers. For the DirectTV, that seems to behave correctly since we actually mean "the back/exit" button and not the previous command. We are discussing if we should add this as a long press to it

      Thanks for staying with us and helping us to get this figured out, I am sure we'll figure out a solution.

    • Patrick Somewhere along the way I commented that I had two units. I experience problems with both Brains, however, the loss of NEEO link occurs on the Family Room Brain/Remote. The bedroom Brain/Remote seems to retain the NEEO Link. At least it was yesterday. 

      Also, the bedroom Brain will also disappear from the Network, albeit less frequently.

      Regarding the DirecTV and the Back button. In my experience pressing the Back button on the remote does not function like the Exit command. It consistently takes the DirecTV UI back to the last menu/guide that was open on the screen. The Exit command should simply close any open menu or onscreen message displayed by the DirecTV UI. It also doesn't reliably go back to the prior displayed DirecTV UI screen displayed.

  • I received a replacement NEEO Combo last Friday and set it up Saturday morning. I have been using the new unit over the weekend with I am happy to say, no issues. I have had none of the problems I was experiencing with the first unit. The Brain now stays connected and available on the network, NEEO Link stays active, the remote stays synced to the Brain and the app quickly and easily finds both of my Brains quickly and repeatedly. 

    The only small wrinkle I had came when setting up the new Brain. The new remote somehow paired itself with the Brain I have in the upstairs bedroom. I can't figure out how this would happen as the remote was brand new and I never tried to pair it to the bedroom Brain. I had to "nuke" the remote by shutting off then holding the power and mute buttons to put it into rescue mode then select the full firmware recovery mode. I was then able to re-pair with the family room brain. 

    Interestingly, the bedroom Brain has had none of the issues I had been experiencing with it either since replacing the family room Brain. The only thing I can figure is that something about the family room Brain was interfering with the network somehow, although I can't fathom how the would be. 

    Anyway, all seems to be functioning properly.

    My only remaining "issue" is the functionality of the remote display. It frequently "double" swipes when moving between screens. I've replicated this many times. It happens intermittentlyregardless of how long of a swipe use try or where on the screen I touch to swipe.

  • Matt Lippmann Wow, I am very glad to hear that! 👍 Thanks for staying with us through this odyssey. Our hardware engineering team will be analyzing this NEEO Brain very deeply!

    We have been able to reproduce the horizontal double swiping, so we will surely be able to fix that soon. This might not make it in the next release since we think there is more than just this that could be improved by swiping. We want no make that feel way more natural generally. So we will complete that as a package.

    Keep us updated on how things behave. Once I know more about that assumingly defective NEEO Brain I will let you know.

    • Patrick No problem Patrick.

      Any thoughts on the remote randomly pairing with a Brain its was never connected to? To be clear, the new remote paired to an existing Brain before I had a chance to try pairing it to the new Brain it came with. Once I got it paired to the proper Brain it has stayed connected correctly.

Like Follow