TV Panasonic TC-P42G25 -- please add a preceding EXIT so it works again

Andy   The physical buttons for CHANNEL UP and CHANNEL DOWN and the CHANNEL FAVORITES options do not work (half the time).  You can easily fix this if you precede those commands with an EXIT command.  (That will cause the TC-P42G25 to exit WEB TV mode and to again accept TV commands.)

This is for TV,  Panasonic TC-P42G25

Fyi I provided lot's of details at https://planet.neeo.com/r/y7nykf but was maybe too much, as you didn't respond.

Thanks!

Reply
17replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Bill Kaczmarek

    This was just added! The new data should appear around 12AM CET.

    Thanks!

    Reply Like
    • Andy sorry, it didn't update. Waited 75 minutes, still see version 27.   Try it again?! Thanks!

      Reply Like
      • Andy
      • Andy
      • 2 mths ago
      • Reported - view

      Bill Kaczmarek 

      Did you try updating manually - like it was before the autmatic update was introduced? Also, the version wll not raise. The version only raises when a code is changed, added or deleted. Adding a prefix for the channels does not raise the version. Please try the following:

      - Check if it already works and got updated anyway
      - Manually check for an update and see if it works now
      - If not, delete and re-add the device. This will get you the new data for sure.

      Hope this helps!

      Reply Like
    • Andy Got it.  You are right, the FAVORITES are now working. Still no luck for the PHYSICAL BUTTONS to turn the channel up and down. Can you look at those too please? I imagine they too just need a preceding EXIT.

      Thanks!

      Reply Like
      • Andy
      • Andy
      • 2 mths ago
      • Reported - view

      Bill Kaczmarek 

      Added! The new data appears around 12AM CET.

      Reply Like
    • Andy So much better to have buttons that work. Thanks!  Could you add a command for a LONG HOLD of the Menu button...  it should trigger MENU SUB.   

      Thanks Andy!

      Reply Like
      • Andy
      • Andy
      • 2 mths ago
      • Reported - view

      Bill Kaczmarek 

      This should already be implemented. Please add the command MENU SUB to the shortcut screen. Thanks!

      Reply Like
    • Andy  For the PHYSICAL BUTTON  entitled "Menu", can a SHORT HOLD of the button trigger something and a LONG HOLD of the button trigger another thing?

      The SHORT HOLD of the "Menu" button now triggers the command MENU.

      I'm requesting you to assign the LONG HOLD of the "Menu" button be made to trigger the command MENU SUB 

      Yes, I have a Shortcut for MENU SUB.  But it would be better if it were triggered by the physical button, if possible.

      Thanks Andy!

      Reply Like
      • Andy
      • Andy
      • 2 mths ago
      • Reported - view

      Bill Kaczmarek 

      For all TVs and set top boxes: Short press on menu hard button opens GUIDE, long press opens MENU. This cannot be changed. See here for all secondary mappings: https://planet.neeo.com/t/h427jl/secondary-mappings-of-the-hard-button-on-the-neeo-remote

      Sorry!

      Reply Like
    • Andy ok, got it.  Since GUIDE apparently doesn't exist for this TV, it seemed like there was nothing assigned.  I hoped it would be as easy as your filling in the empty blank with a desired command.  Pity to have a button not work, but it sounds like a lot of work to code it individually for this model.  Too bad, but thanks anyway!

      Reply Like
      • Andy
      • Andy
      • 2 mths ago
      • Reported - view

      Bill Kaczmarek 

      It's because of guidelines we have to follow for every device class. I was not aware that you don't have a GUIDE button. This is a rare case where I can make an exception and put the menu on short and menu sub on long press. But this is an exception and only possible as there is no guide button. The new data will appear around 6PM CET.

      Reply Like
    • Andy Fabulous. Thanks Andy!!

      You may find interesting - and maybe not ;-) - that the MENU command response depends upon which mode you are in, TV or WebTV or VieraLink.   (GUIDE does nothing in any mode.)

      In TV mode: 

       - MENU opens general TV picture adjustment settings.

      - MENU SUB opens guide-like info (list of channels, whether channel up/down command returns only Favorites or returns all available channels) and signal strength meter.

      In WebTV mode:

       - MENU returns an option to go to VieraLink or to begin recording video (and a couple other special options)

      - MENU SUB does nothing

      In VieraLink mode:

      (which is both a Skype-like video-link and a TIVO-like DVR):

      - sorry, I don't know as I don't have the camera and so cannot enter that mode.

      Reply Like
    • Andy p.s. any chance it is possible to sense which mode is active?  Ideal would be to have LONG TOUCH trigger Menu Sub IF IN TV MODE and trigger VieraCast IF IN WEBTV MODE.

      Didn't think so, but had to at least ask!  Thanks

      Reply Like
    • Andy p.p.s I have updated and found a surprise.  I've also found a new issue.

      EDIT! IGNORE #1 BELOW - THE REMOTE JUST UPDATED AND NOW MENU AND SUB MENU ARE WORKING AS EXPECTED. SORRY!

      1) Both short-hold and long-hold of "menu" physical button are now the same, both seem to be SUB MENU. (which is the one I prefer).  Neither is MENU. 

      (I say that because for both short and long hold:

      - in TV Mode, SUB MENU comes on screen for both

      - in WebTV mode, nothing appears for either)

       

      2) Also, I've found an issue now that I'm launching APPs 1-4 from TV Mode (which wasn't done until I merged into a single Recipe for both WebTV and TV.)  

      Please add a Pause, maybe 0.5 - 1 second following the initial VIERACAST command at the start of APP 1, APP 2, APP 3, and APP 4. Maybe that will be enough to fix the intermittent issues - they work perfectly maybe half the time.

       

      Thanks!

      Reply Like
    • Andy  SORRY! IGNORE #1 IN THE POST THAT BEGINS P.P.S.   SINCE I WROTE IT, THE REMOTE UPDATED FULLY, AND NOW MENU AND SUB MENU ARE WORKING AS EXPECTED. SORRY!

      Reply Like
    • Andy p.p.p.s. Sorry, more. 

      EDIT:  RATHER THAN THE BELOW, THE FOLLOWING IS BETTER AND EASIER.

      LEAVE THE SHORT TOUCH OF THE MENU BUTTON AS IS, ACTION=MENU

      CHANGE THE LONG TOUCH OF THE MENU BUTTON TO ACTION=VIERA CAST (RATHER THAN MENU SUB)

      FOR NUMPAD "GUIDE" USE ACTION=MENU SUB (AND LEAVE THE LABEL AS "GUIDE")

      IGNORE THE FOLLOWING.

      The NUMPAD now, for the first time, has on it opposite of "Info" appearing "Guide".  Guide triggers MENU which are the settings for the TV. 

      Could you please replace the label "Guide" with the label "Settings" instead? As is, it is confusing.

      Further, for the short hold of the physical button MENU, can you please replace the current command *Menu* with the command *Viera Cast* instead!  It is much better because the command Viera Cast is *always* useful - it is the menu for both TV mode and WebTV mode. In contrast, Menu doesn't give a response half the time (it works only when you are in TV mode, and does nothing when you are in WebTV mode).  And worse, it gives the infrastructure settings that are only rarely used anyway.

      Andy, thanks for all your help!!

      Reply Like
    • Andy see the edits correcting the post which begins "p.p.p.s."

      Reply Like
Like Follow